Does Lucene Index still work?

I know Lucene Index is deprecated, but is it still working? I’ve got a couple of new installations where I can’t get it to work. I’m getting a fatal error that it failed, but nothing more. I’ve done all the usual stuff like:

  1. permissions
  2. file ownership
  3. checked who cron jobs runs as (allowed cron users)
  4. deleted the Index folder, and DB entries to re-create the index (I’ve done this dozens of times in the past and it has always worked).

I don’t know what else to try. Just wondering if it is now completely defunct?

It’s working. Have you checked that FATAL? It’s probable already here on the Forums, or on Github.

I bet it’s one of those PHP 8.x bugs

Thanks, @pgr, I just solved it. My server is running on PHP8.0 but I normally have SuiteCRM running on 7.4. in the subdirectory. The cron jobs however run on the server PHP version. As part of troubleshooting I ran cron jobs as ea-php74 just to make sure it wasn’t a 8.0 thing. However, I neglected to up the memory limit of PHP7.4 on the server. I upped that and it works!!! OMG, that’s a day and a half I won’t get back for something so silly. Well, hopefully if someone else has the issue on more thing to check is the memory allocated to the server version of PHP in WHM.

I have a test install running cron jobs on PHP 8.0 and it works, so the issue was the memory limit allocated to the PHP version, not the version of PHP.

Anyway, it wasn’t a total waste of time. I have another client with the same exact issue. I bet the solution is the same!

1 Like