Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Documents upload failed - Suitecrm 8

Hello there,

I am using Suitecrm 8 and I am not able to upload a document using the path “Documents” → “+ Create Document”

Once selected the file and filled few informations I click the “Save” button and after a while I get the error
displayed in the following screenshot.

The file is a small .pdf file, I tried with a .doc file the same. I tried with the previous Suitecrm version using
a Virtual machine, no problem.

Anybody any idea?

Thanks for helping out.
Mario

Hi
As per your query, I uploaded and successfully worked in SuiteCRM 8 Version on Document Module. There is No issue I faced with PDF or. Doc formate uploading.


Maybe the issue is in your Legacy permission.
Or go for:
ini_set(‘display_errors’,1);
error_reporting(E_ALL); for error log display.

Hi Vijay,

Thanks for replying.
I understand it works for you, but yesterday I tried several times and no way.

You suggest to “go for:
ini_set(‘display_errors’,1);
error_reporting(E_ALL); for error log display.”

Can you please be a little more specific what I should do? I am not so expert.

Thanks for letting me know.
Mario

Hi @mariofucile,
you put this command on an index.php
image
this is on the SuiteCRM8 public folder.

@mariofucile Best to not enable this via the index.php

There is a tick box in system settings called Stack Trace which can be ticked on simply. It should give slightly more info.

I would suggest first however checking your suitecrm.log file which should hopefully point you in the right direction. This will be located within public/legacy/suitecrm.log

Hi Macr-Rae and Vujay,

First of all thanks for your time.

The problem now seems to be resolved. The issue was apparently caused by the php version in use.
I’ve set to run on 7.4 instead of the previous 8.0 and now seems to be working.

Despite what stated in the installation page, could it be possible that Suitecrm 8 does not really
support php version 8.0?

Thanks.
Davide

2 Likes

Hi @mariofucile,

Both versions are supported tho I’ll look to confirm if this is a stand out issues :+1:

Hi Mac.Rae,

I get back to this post as I would like to update you about the issue encountered on uploading&displaying “Documents” in SuiteCRM.

I installed another instance of the SuiteCRM 8.0.1 version and get the same issue.
Then for other reasons I moved and installed SuiteCRM 7.12.5 and even there get the same bad result (no upload&display documents).

No errors recorded in the suitecrm.log file for both cases.

In both cases documents were in the “upload” directory (permission 775).

The only way to solve it was to change the php version (FM the 8.0.16 to 7.4.28) as I did before.
Once changed I could immediately display all docs previously uploaded and upload new ones.

What do you think? What could cause the issue using the php 8.0.16?

Thanks
Mario

There is probably a FATAL error in your PHP log. Usually it’s called php_errors.log

Hi pgr,

I found an error_log under my subdomain directory and inside there are 5 lines with Fatal error. Actually the first 3 are the same and the remainig 2 are the same, related to SuiteCRM installation. All dated April 21st.
Do you mean that just deleting those lines SuiteCRM should work with the php 8.0.16 version?

Thanks
Mario