Documents module - documents won't download / HTTP ERROR 500

Hi everyone!

I am encountering serious problem with Documents module for some time now (version 7.7.7 and 7.7.8):

  • when I upload document and put in all relevant information, it saves correctly and shows file name
  • when I try to download attached document from Documents detail view (click on file name hyperlink) new window opens and I get Http 500 error!

Tried to repair everything from admin panel, but w/o success.

I have installations both on MySQL and MSSQL servers = same problem.

My environment: Windows 2012 R2 server, IIS8.

I tried the installation on Linux server and it was working fine… (?)

This is a quite big bug/problem for CRM system = not being able to use Documents module… :frowning: and I must stick with Windows 2012 R2 server for this installation…

Can anyone help, as I have no idea whay this happens.

Many thanks in advance!



I have the same problem after upgrading to 7.8. I get an error 500 when I try to click on any of the file name hyperlink of a document I previously uploaded.
My environment is Windows Server 2008 R2.

Does anyone have any idea why this happens or how to fix it?

Thanks a mill

Hi Leonard!

I resolved such problem by changing PHP version to 5.6.24, as nothing else helped…

Hope it will help to you as well.

Have a nice Suite day! :slight_smile:


Thanks for your replay Mario.

I installed the PHP version that worked for you, but no luck. Another instance on the same Windows server but on version 7.7.1 works perfectly and the permissions are the same for all IIS folders. I’m so lost but will continue to try and find a solution.

Kind Regards,

Check your logs, if you have an http 500 error, you should have an explanation waiting for you in the logs… you can work from there.

Thanks a mill. I realized after checking the PHP error log file that the fileinfo dll was not registered in the PHP.ini file. All sorted