Disable implied wildcard in filter fields

We have different accounts with similar names, that is names with the same beginning and different ending.

We’d like to filter the exact name of an Account but we always get all the accounts with same initial part.

E.g., in Opportunities module, if we enter “FERRARI s.p.a.” in the “Account Name” field of the filter, we obtain

FERRARI s.p.a.
FERRARI s.p.a. (Customer Management)
FERRARI s.p.a. (F1 Department)

We’d like to obtain only the first result.

It seems it adds an implied wildcard at the end of the entered string. Is it possible to avoid this insertion?


There are several kinds of search in SuiteCRM, which have you enabled in Admin / Search Settings?

There is also an option in config_override.php called

and another

do you have any settings there for these?

Try setting search_wildcard_infront to false, it should solve your problem.

Do those Search Settings apply to module filters? My issue is with the filter, not with Global Search. We use the filter to make Global Updates on results (you can’t do Global Updates on Global Search results).

The parameter “search_wildcard_infront” is already set to false. However, it adds the wildcard IN FRONT of the search term (LIKE “%FERRARI”). Instead, I would like to remove the one BEHIND, that seems to be implicit.

(I think what you’re calling “Global updates” is “Mass update”)

If you’re talking about searches from the List view filters, then no, I don’t think this applies. I don’t know of any way to change search behavior in filters.

Of course, if you go looking in the code you might find a place to change this.