Delete Multiple Records

Hi All,

I am using SuiteCRM 7.6.4 version.

I am unable to delete multiple records from my suitecrm custom module. It gives error:

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32 bytes) in /modules/AOD_Index/Lib/Zend/Search/Lucene/Storage/File.php on line 194

I have searched for a solution for the error wherein it said to increase the PHP file upload limit & memory size, I have increased the PHP limits, however, its still a no go.

I was getting error to import the records, Error 503 Timed Out, as well wherein it suggested to disable the AOD settings post which the import works.

Please advice how to resolve the multiple delete issue.

I am not a developer, please guide me.


I think this might help you.


Hi Prafull,

Thanks for the reply. I tried both the options, however, I am still getting the same error, any other suggestions that I can try?


I work via MSACCESS2013 ( if Local SuiteCRM) , then ODBC ,select LINK, select tables, etc etc and then you can make query and Updatequery or delete whatever.

Thanks for the reply William.

Mine is on the hosted server. Also, all users don’t have access to the backend (MySQL Database).

I was looking for a solution wherein the users should be able to delete it. This was working fine initially when it was installed.

Is there any settings that I need to check to resolve this issue?


What Petrovils said about accessing the database in Windows, can also be done in Linux via phpMyAdmin. I don’t know which system you’re running.

Your original error seems strange to me. The AOD Indexer is using up 583Mb of RAM. I wonder if it’s going in an endless loop or something. Do you have a huge database? Are you trying a huge delete operation?

this is your php process is running out of allowed memory, change your php.ini file and set memory_limit to 1024MB just for that purpose, then change back to the original value, of course you need to restart you apache service after each modification.

best regards

Hi All,

Thank You for the suggestions. No, I am not deleting a huge data, about 100 records, I have tried to increase php limit to 1024 MB, but its still a no go. Any another suggestions I can try?


i’m pretty sure that you’re not modifying your setting correctly, please look again. Remember that there are many php.ini files you can modify and also depends on the OS that you have.

best regards

Yes, Mike is right, I have 3 php.ini files in my system! Only one of them counts!

Anyway, you can check if the error you’re getting now reflects the increased limit or not.

As a different route altogether, you could try deleting the AOD Lucene Index, and do your operations. The Index will eventually be rebuilt. There are posts online explaining how to do this. But this could be overkill, especially if you have a large database. Make sure you have a backup before attempting it, also.

Hi All,

Thank you for all the suggestions.

I checked, I have only one PHP.ini file.

The configuration is -

max_execution_time = 6000
max_input_time = 5000
max_input_vars = 5000
memory_limit = 1024M
upload_max_filesize = 750M
post_max_size = 500M
max_file_uploads = 200
// Turn off all error reporting

// Report simple running errors
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// Reporting E_NOTICE can be good too (to report uninitialized
// variables or catch variable name misspellings …)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// Report all errors except E_NOTICE
// This is the default value set in php.ini
error_reporting(E_ALL ^ E_NOTICE);

// Report all PHP errors (see changelog)

// Report all PHP errors

// Same as error_reporting(E_ALL);
ini_set(‘error_reporting’, E_ALL);

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

display_errors = Off

; Defines the default timezone used by the date functions
date.timezone = Asia/Calcutta

I am pretty sure I have messed it up somewhere in the above.

Please let me know if the configuration is correct or if the changes I should make to get this sorted?


Your error used to say

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32 bytes) in /modules/AOD_Index/Lib/Zend/Search/Lucene/Storage/File.php on line 194

Now that you changed the memory limit to 1024MB and restarted Apache, does the number in the error change?

Its still the same

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32 bytes) in /modules/AOD_Index/Lib/Zend/Search/Lucene/Storage/File.php on line 194

That’s weird.

Double-check your php.ini files with
find / -name php.ini 2>/dev/null

Check how big your AOD Index has become with
du -h modules/AOD_Index/Index/Index
(do that on your SuiteCRM home directory)

Could you actually be running out of available physical RAM?

I checked the code on that line 194 and I can’t say why it’s breaking there, but for me, it suggests two directions of investigation: the size of the AOD files, and any strange behaviors caused by PHP versions / bugs.