Delete field in studio

Hello everybody,

I have a problem but i’m not sure he’s due to the theme. When i want to delete a field in studio i click on “delete” button but nothing happened. I have an error message in the console of my firefox and i don’t understand why. I join the picture of the error message. I have no error message in the logs files.

Can you help me to repair that ?

Best regards.


I am able to delete fields without issue in 7.7

What version of SuiteCRM were you trying to delete fields on?

What theme were you using?

Does this happen for all fields, or is this an issue only on specific fields?

Hi John,

Thank’s for replying.

I’m using the 7.7 Released version of suiteCRM(latest version)

I’m using the suiteP theme.

This happen for all fields, I can’t delete fields in the studio.


Thanks for the info!

I assume the field you are trying to delete is a custom one?
(I.e, one that was created manually in studio)

Would you be able to pass over a screenshot of the field itself?
(I.e, the screen that shows the field’s info such as: Data Type, Field Name, Display Label)

Also, If you try to delete a field in another browser, such as Google Chrome, are you able to do that successfully?

Yes the field i’m trying to delete is a custom one.

Yes i join you a screenshot of the informations about de field.

I have try in another browser but it’s the same result, when i click on delete, nothing happen.


Thanks for the update.

You mentioned that this happens for all fields.

Would it be possible to provide a screenshot of any other fields that you are unable to delete?

You also mentioned that you are unsure if it is related to the theme.

If you select another theme, (Which can be done by editing your user profile), are you able to delete fields without issue?


Thank’s for the time you take to resolve my problem.

Yes of course, i join two others screenshots of two other fields i’m unable to delete.

Yes, i develop on suiteCRM since three month and i have see this problem before, due to a cote (symbol ’ ) which is not close.

I have selected an another theme and try to delete fields but i have exactly the same error, so i really think that related to the theme.

I have programming notions, so you can use “technical terms”

*I really think that’s not related to the theme.


Commenting with bumps just clutters the topic and won’t get your posts responded to any quicker.

In regards to your issue, is this an issue in all languages. i.e. what happens if you try it in the default English system language.

When you click delete, do you receive any browser console errors(Ctrl+Shift+J in Chrome, Ctrl+Shift+K in Firefox, F12 in IE)?



1 Like

Hi Will,

Thank’s for responding.

Sorry for commenting.

I try in English language and that work ! So i will set my system to english when i want to delete a field.

And yes i have errors in my console. This is the screen of my first post in this topic.

Best regards.

The issue is therefore with the language pack, and not with SuiteCRM itself. I’d contact the vendor for the language pack you’re using.



Ok, Thanks.

If you need some informations about the vendor or the package i’m using, don’t hesitate.

Best regards.

You will need to follow up with the vendor/package provider. They will need to fix the bug/issue within their language pack.



currently the problem is always there :
change in LBL_CONFIRM_FIELD_DELETE the quote with &#039 and it works now.

@Christophe84 which SuiteCRM version are you on? And which language pack, exactly?