Date Fields Indexed as Strings in ElasticSearch

Hi there,

I’m working with SuiteCRM version 7.11.14 and recently enabled the built-in Elasticsearch integration, which works great. I’ve noticed, however, that all of the date fields (,, etc.) are mapped as String types, despite being DateTime fields (as shown in the SuiteCRM Studio). I know that Elasticsearch does a pretty good job at autodetecting date/time fields, so I find this to be curious. Has anyone else run into this issue? If so, what workarounds might be available? At present, this impacts my ability to take advantage of some of Kibana’s time-based visualization features.

It’s not possible to update the _type mapping type in Elasticsearch, so I’m wondering if I need to:

  1. Disable ES indexing in SuiteCRM
  2. Create a new index (main2) with the correct _type=date mappings and reindex my data into that index.
  3. Delete the old index (main)
  4. Copy the new index from main2 to main
  5. Delete main2 index
  6. Re-enable ES indexing in SuiteCRM

I’d appreciate any help on the matter!