date and time error


I noticed that I have some issues with dates and times.
My suitecrm is setup for France, with this format for dates : dd/mm/aaaa
But I noticed that all the dates are displayed with the english format.

I googled and understood it might be a php.ini issue but I’m on a shared hosting so I have no way to change it.

As it’s not very important, I gave it up.

But today I created a note and noticed that I had a 2 hours delay between the note creation hour and the actual hour.
Same thing I guess the time zone must be set on greenwich time instead of Europe/Paris.
This point is very important so I need to fix it.

Any idea of how I can set my own parameters for php.ini on a shared hosting ?
I already googled but wasn’t able to find the answer…

Thanks for your help.

Some possibilities:

  1. your hosting let’s you change that somewhere in CPanel

  2. your hosting will change that for you if you ask them in an email

  3. your hosting will pick up a small php.ini file that you create in your root directory, and will apply it for you, with restrictions. But date.timezone is usually allowed. you only set this setting in your php.ini, not others.

There are more option if these don’t work, but let’s try exploring these first, since the others involve changing code in all the entry-points, and they are not upgrade-safe.

Thanks for your answer.
I had tried something in the meantime :
I clicked on my profile settings, in “advanced” tab and there I was able to choose “Europe / Paris” and the other local settings.
Now when I add a new item, it’s addded with the correct date and time.

I tried being logged with another profile and it’s ok.
However, there’s something that I have to set up for each emplyee it’s date format and hour format.
It’s a pity because it should be the same format for every employee.

Do you know if there’s a way to set date and time format for everyone ?
I tried in Admin / Local parameters : it’s set for French date and time (dd/mm/yyyy) but for some reason my employee don’t have this format by default.


1 Like

I’m glad it’s working now.

I don’t know of any way to set a default for new employees. Of course you can go looking in the code and change that, but it’s probably not worth the effort unless you have a ton of employees, do you?