Database update after create custom fields

I have created some custom fields in the Accounts module, and when I update and repair the database in Studio → Repair → Quick Repair and Rebuild, I can’t see the new fields integrated in the database, why?

Are the fields already added to the db? Usually, when adding fields in the studio, they are directly created and rr is not needed.

They are not created, I have created them and integrated them into the views and nothing.

image

Hi,
those fields are not added to the “main” table, but to the custom one (so e.g. accounts_cstm instead of accounts).

So the fields will be synchronized with the main table but will appear in another?

Hi,
not exactly. When adding fields in the module builder, the main table will be used. When adding fields in the studio, the table with the _cstm suffix will be used.
During runtime, Suite automatically joins both tables and you do not need to handle anything specifically (unless you want to work on database level directly).

1 Like

Thank you very much, I have been entering data and you are right, everything works now.

Hi @crmspace,
i create two fields from Admin/Studio and search that fields from opportunities_cstm table but it is not there. Please help me.
image

Are those fields representing a relationship? In that case, also look for new tables, they are usually named like <moduleA>_<moduleB>_c (names are often a bit scrambled due to the length of the complete string).

1 Like

Thank you for your response.
it is working now.

1 Like