Database connection error after installing suitecrm V 8-3-1

It does not connect to my mariadb v 10.9.8. I’m sure all the credentials are correct. I’m using RHEL 8 and PHP 8. Please advice thank you

Look for a .env file in your root.

This file will tell you which environment you’re running (local, test, dev or, most likely: prod).

Then look for the corresponding file such as, you should find a MySQL connection string there, fix it.

There are similar settings for legacy in public/legacy/config.php, look for a setting with database configs, I don’t recall exactly what it is called.

I tried searching for using the following command but couldn’t find it.
Here’s a screenshot:

Here’s a sc from /root/.env :

I meant the root of your SuiteCRM project, so it’s probably


which includes that APP_ENV=prod

which sends you looking for a MySQL connect string in


1 Like

I’m looking for but there is no such file. And there are many files with the name config.php (refer to sc attached above).

Solved it.

It was SE Linux issue

setenforce 0

Solved it :slight_smile:

1 Like

This is not a solution.
The solution would be, for example, to tell how to use ausearch to find hits on SELinux, understanding the hits, and allowing the action.

Disabling SELinux is layman work.