Data types in fields

i want to create a field inside a modul to represent the ID of a customer
when i set the datatype of that field to integer it adds a " . " to the customer ID
For example the customer ID ist 99808 but on the field i see 99.808
what is the problem here?
is there another data type suitable for this field ?

Do you have anything entered in the Default Value, Min / max Value, or Max Size?
Have you edited the field in the database at all?

Hi Jordan, it depends by your international settings
Administration page > Locale

Profile > Advanced tab > Locale Settings section.

If the ID field you created is of these types:

  • currency,
  • decimal,
  • integer

it will be formatted as per your Locale Settings.
I suggest you to use a text field.
By the way iā€™d also do some autofill on it with leading zeros to help you to order by that field (on ListView)

i used a text field and it worked

thanks for your reply

You can use an integer field and check Disable Format in Studio.
Then 1000s separator will not be used