dashlet navigation broken

I just upgraded from 7.6.5 to 7.7.4

Now using any theme EXCEPT Suite P the navigation no longer works.
BUT using Suite P it works…

Most users won’t use Suite P because of the distance between controls, many are still using classic theme!

Can I fix this myself?


just to add…

tried with Chrome, I.E, 11… on 2 systems, dev and production instances, even tried with fresh test instance, not an upgrade…

I tried repair all possible choices from admin menu

even tried from iphone so not related to computer even if I could replicate this on 3 separate machines…

Is this an easy fix?

just noticed, might be related to https://suitecrm.com/forum/suitecrm-7-0-discussion/11236-pagination-in-dashlets-not-working


I am able to replicate on a local 7.7.4, when using the SuiteR theme.

You may wish to raise this as an issue on our github repo, to allow for a developer to investigate.

Please feel free to raise it here! : https://github.com/salesagility/SuiteCRM/issues/new


1 Like

The problem as far as i can see resides in this file:


In here we can find this:

if you change that line to:

Repeat for all four buttons and the navigation buttons will work again at least in the SuiteR template. But it will break SuiteP.

I’m trying to find the definitive solution.

I’ll let you know what i find.