Custom module not able to "Save" or "Edit" record

SuiteCRM 7.3.1
Operating system Ubuntu Linux 14.04.3

I am new to this CRM system, so please forgive me for asking stupid questions.

I build this package of modules by the “Module Builder” and deploy + quick repair and all looks fine …
However, the module “Share Transactions” doesn’t let me save on create, quick create and edit pages, either not responding or display ‘There is no action by that name.’
I tried to insert new record by phpmyadmin and the record display on suiteCRM correctly, but if I click on the record to edit the save button is not function al too.

I been trying to search on google and apply few changes, but no luck.

I have even try building another package for the transaction module but still not working, so it must be something wrong in it because other two custom module works fine …

thank you for reading and helping
Shou-li Hsieh

After Investigate one by one … The issue is cause by the “Action” field in EditView, I think it may be the reserved key word.

However I rebuild the module and change the name of the field, all good this time … B)

so the problem is solved just like that … 100+ hair off in a week just for a little issue with field name … :pinch:

Anyway thanks anyone who may try to help …