Custom Module Error, partly no subpanel, not showing up in search

Hi ,

i got a strange behaviour in a custom module i created in module builder and deployed after that.

In general the module works well and is already in a productive environment. Afterwards we now realized that for 1 relationship to Accounts module (1 Accounts to many of the custom Module) no subpanel shows up in Accounts.

The module or Subpanel is not hidden, it shows up in the list of visible modules in the admin section. The relationship is there and defined.
Other relationships of the module, for example to another custom module show subpanels without issues.

I noticed that for all custom modules showing a subpanel in Accounts i got a file named

“_overrideAccount_subpanel_relationshipname.php” in /custom/Extension/modles/Accounts/Ext/Layoutdefs

which is an auto created file for the subpanel. This file is missing for the subpanel of the custom module. The File for the relationship itsself is there.

For test purpose i tried to create a new relationship with different name but between the same modules of same type in Studio. Doing this, an error occured and in the logs i got following:

Wed Nov 8 14:22:22 2023 [26226][ca300054-c9d3-e696-2ef3-5da5b1002ec2][FATAL] Exception in Controller: Subpanel was not defined
Wed Nov 8 14:23:17 2023 [25385][ca300054-c9d3-e696-2ef3-5da5b1002ec2][FATAL] Exception handling in /srv/www/vhosts/zmsales/suite/include/MVC/Controller/SugarController.php:397

Now i additionally noticed that also that specific module is also missing completly in Search Settings. Its neither showing up under Enabled Modules nor under Disabled Modules.

Anyone has an idea where this is coming from? What is responsible for creating the _override file mentioned above?

I am running Suite 7.14.1 with MariaDB 10.6.15 and PHP 8.2.10

Hi, welcome to the Community :tada:

Try a “find in files” from the root of your SuiteCRM installation:

grep -irn text_im_looking_for .

(that ends in space + dot)

Look for the name of your relationship.

Hi @MrBK , great to have you in the forum.

To help people here respond most helpfully - what level of Suite knowledge do you have regards Custom modules: have you built some in the past or is this the first?

Also are you a deep PHP guy, or new to PHP?

@pgr tip for searching inside files on Linux - is the right tool here. Be aware that if you want to search for text with a space inside it, you’;; need to quote it:

grep -irn "text with spaces im_looking_for" .

You probably knew that, but just in case for anyone else reading.

Dear All,

thanks for your help. To anwer your questions: we use Suite since roughly 4 years now and i built several custom modules for it. Issues like the above have not occured so far and the other modules run well.
Regarding PHP, even if i stopped programming some years ago, i might be not up to date latest developments but i am able to dig into topics :wink:

Regarding this strage behaviour described in my original post, i was able to correct it. In Module Builder i created the one to many relationship between the custom module and Accounts module. I have now noticed that in the deployment of the module, suite created instead of one relationship 4 relationships of this type with the same name. Only a underline was added in the label and the relationship name an increasing number was attached. This combined with a wrongly given label, made me not finding the subpanel in Accounts. After noticing that, i removed the not needed relationships in Studio. Unfortunatly i was not able to rename the relationship via Studio, but did this manually via Extension Framework. So now all good on that end.

Now the only open issue remaining is that this custom module is not showing up in the Search Settings. Its neither showing up in Enabled nor Disabled Modules. Is there any way i can add this module to the searchable modules?

Thanks for your help!


Maybe this will help

Thanks for the link to this post. I did all steps and after a couple of repair and rebuilds the module showed up in the search setting.

So again, thanks for helping me out!

1 Like