Custom Entry Point redirects to the SuiteCRM index page


I have created a custom entry point in suite with the help of the following documentation

and then I tried to access the entrypoint using below methods but it is redirecting to the index page .

1- http://{sugar url}/index.php?entryPoint=customEntryPoint
2-http://{sugar url}/#bwc/index.php?entryPoint={entry point name}

My SuiteCRM version is 7.7.6 , I dont know why it is not working even I follow the same methods mentioned in the sugar guide. Is there any other documentation for the SuiteCRM entrypoint?


what does your entry point do? I’ve tested this in the past and was working for me

best regards


My plan is to create an entry point to make the event delegates or participants status accept or decline,
For example. When we creating an event it ask for accept url and decline url. so I found that entry point can do this work. In the entry point file I will make some to change the status of the event based on the url parameters. Possible?


yes it is possible, I would suggest to you to try simpler things just to test if your entry point is working or not. I’ll personally test one on my own and give feedback to you.

best regards

Yes please, That will be very helpful.

Thank You

HI Mikeback

Did you try this, Can You help me on this
If it works can you please upload it to the GIT, It will be very helpful.


@nadill I’ll test it today, don’t worry

best regards

Check that after running the repair and rebuild that the entry_point_registry.ext.php file located in custom/application/Ext/EntryPointRegistry contains your entry point

If you’re being redirected back to the home page when trying to access an Entry Point, then it’s most likely the Entry Point name you’re using isn’t registered, or at least isn’t being loaded.

I’m assuming you’ll have double checked that the name in your URL exactly matches that of the Entry Point you’ve defined, so it may be a permissions issue, as if the user Apache runs under can’t access the /custom/application/Ext/EntryPointRegistry directory, it’ll not be able to load and add your Entry Point entry into the relevant array.

To be on the safe side, try the following from the SuiteCRM base directory:

chmod 775 custom -R

Also ensure that the case of the Entry Point name you’re passing on the URL matches that of your definition, as on Linux system it’s case sensitive.

Hey, having the same problems with multiple versions of Suite. I have tested this on 7.8.7, 7.9.3, 7.9.4 and 7.9.6 all with the same results. I create my custom entry points in custom/Extension/application/Ext/EntryPointRegistry and run an Admin repair/rebuild. The entry_point_registry.ext.php file is created at custom/application/Ext/EntryPointRegistry and it contains the content from my custom entrypoint files HOWEVER the functionality NEVER works. If I create an entry_point_registry.php file in custom/include/MVC/Controller and run an Admin repair/rebuild the functions work. I have tried all the recommended stuff, file/folder rights, rebuild, check syntax (REMEMBER they work from custom/MVC/Controller!!!) to no avail. I don’t think the entry_point_registry.ext.php file is being referenced…

I have also attempted to use the menu.ext.php framework to add shortcuts to module menus with the same result, the correct file is created but the functionality never works…

Is anyone else finding this behaviour when using the Extension framework? Any thoughts gratefully received