CSV Import not working on SuiteCRM

Hello Everyone,
So I am new to the SuiteCRM. I have been exploring this CRM for a small project at work. Although I am having issues with importing the contacts thru the CSV file. I tried looking around for solution but nobody seems to have a similar issue like the one I am facing, and hence I resorted to write to the forum myself.

What have I tried so far?
When I imported my original CSV file (exported from the previous program I was using), it only imported 1 out of the 70 contacts. Hence I downloaded the CSV template from SuiteCRM and filled in the details and yet it does not import anything. I even created the custom fields on SuiteCRM so can make them perfectly during the import and still it just wouldn’t import except one contact.

Ironically there are no errors either, so I am just absolutely clueless as it what am I doing wrong. Here is a screenshot of how the result looks like.

Any help would be appreciated guys!! Thank you again so much for your efforts :slight_smile:


I don’t know if this will help but since nobody else responded I’ll give it a shot. I have found that a datatype error (such as a bad email address) in the CSV file will cause it to exit or it could possibly be the “System Setting” that sets the number of imported rows. I believe it’s intended to default to “unlimited” rows but I have found my installation defaults to 100. So in the past if I wanted to import 200 contacts I would need to run the import 2 times. I just changed the value to 2000 rows but I won’t know if that works until my next import. The setting can be found here:
Admin->System Settings->Import - Maximum Number of Rows

Hope that helps,

Please check if your CSV file is wellformed. Columns delimeters and new line delimeters.

If only 1 line gets imported means, there is an error in the following line or at the termination of 1st line.

  • Please check suitecrm.log found in the base directory of your SuiteCRM installation and php_errors.log of your php installation, this will give you idea if something fails.

  • Check and if required increase the below php settings

Also take a look at the import wizard document

I’d also try different CSV formats like “Windows Comma Separated” instead of the regular, you can normally choose the type when you do “save as” in excel

Screen Shot 2020-04-18 at 3.19.05 AM

I am using it so maybe i can help…Did not match the fields in SuiteCRM to the CSV colums? ONLY when the field and column name are identical SuiteCRM will match them. If not, you need to manually select the matching field, or select ‘ignore this column’

Thanks guys I really appreciate all the support. I don’t know what was the problem, but I downloaded the template file and filled in the details again. Left all the fields in the same order as the template. Just replaced the data and it worked :slight_smile: