CSV Export of Report with Multiselect field generates a row per value, not per account

Hello. I have a multiselect field in an account for category. When I export a report I get a row for each category, not a single cell with the multiple values. Has anyone else run into this? I’m trying to export the accounts with their ids so that I can run the import tool and update info. Thanks. ~Trevor


I havent looked however taking a guess the mulitselect field will split the values using a comma and the export delimited that is set by default is a comma,

you can try changing this in the user settings under advanced.

hopefully that helps.


1 Like

Hi Ian,

The issue appears to be with the formatting of the output, not the delimitter.

If I do an export from the list view I get a csv with every field in quotes. That solves the multiselect cell issue. Note the “Apparel-Men, Apparel-Women…” info below, all in quotes.

“Icebreaker”,“b2bf5236-2f32-6e6a-8696-54ab2e1af4fc”,“http://”,"","","","","","","","","","","","","","","","","","","","","","",“3654b5ce-b5e0-d0eb-e742-54ab2ded8eee”,"","","","","",“01/05/2015 01:37 pm”,“01/05/2015 01:39 pm”,“1”,“1”,“0”,“https://maps.google.com?q= {billing_address_street},{billing_address_street},{billing_address_city},{billing_address_postalcode}&output=embed”,“eStore”,“Apparel-Men,Apparel-Women,Sporting Goods",“0”,“http://”,”","",“0.00000000”,“0.00000000”

If I do an export of a report, none of the fields are in quotes, and Apparel-Men Apparel-Women Sporting Goods and so on generate line breaks.

Icebreaker,b2bf5236-2f32-6e6a-8696-54ab2e1af4fc,Icebreaker (Parent),eStore,Apparel-Men
Sporting Goods,http://,http://,

I changed the delimitter to a pipe, and the report export still generates line breaks for the multiselect fields:

Icebreaker|b2bf5236-2f32-6e6a-8696-54ab2e1af4fc|Icebreaker (Parent)|eStore|Apparel-Men
Sporting Goods||http://|http://||||||||

One thing which would solve this would be the ability to have the account ID in the account list view, but I haven’t seen it as an available field. Do you know if that is possible?

Hi tz,

that is very odd that its doing that. how reporting module are you using is it AOR Reports ?

When you talk about getting the account id in to the account list view. I have never tried to put that field into a list view so unsure if it is possible I would think that chances are its not possible out of the box. but there is ways to work round it. could save the ID into another field and display that field would be a easy way round it. maybe done via a workflow.


Hi Ian,

I believe that I’m having the same problem.

I am running a “data dump” report on my Leads. My leads are surgeons, thus they often will have multiple Titles, formatted as such: (RN, NP, PA-C).

When I run the report from AOR, commas in those fields are parsed by Excel as another value in the row - completely breaking the formatting of the CSV. When I export my Leads from the List View, though, everything is completely fine.

Any ideas?

Well, this works.


Although I don’t know how to make it upgrade-safe. I’ve used this once before, but I guess it was overwritten. My reports are working perfectly now.

Which part of that GitHub thread “works”?