Cron working in test server, not working in production

We built the test server first, which has cron and hence the SuiteCRM schedulers running fine. When we change the times for the schedules to run via the SuiteCRM UI, the jobs run accordingly.
Our production server was built next, but whenever we change the Scheduler times via the UI, it won’t change how frequently they run. The schedules run every hour no matter what we set on the Scheduler UI.

Both servers are Turnkey SugarCRM upgraded to SuiteCRM 7.1.1.
Both servers have this line in /etc/cron.hourly/sugarcm

su www-data -c “cd /var/www/sugarcrm; php -f cron.php > /dev/null 2>&1”

Both servers have the same exact cron.php file.

For file permissions, both servers have www-data as the owner of /var/www/sugarcrm

Unfortunately, our production server is broken until we fix this cron. We have some mail tools that rely on it, like SugarChimp integration module.

Any help is much appreciated!

Hi Shane,

Try checking the timezone settings in php.ini on both servers.

You could also try setting your log level to DEBUG, run the cron job and check sugarcrm.log for any references to date and time values and comparisons.



I ran “dpkg-reconfigure tzdata” to set the time zone on both servers to Central.
Nevertheless, UTC is set as the time zone in php.ini for both servers.

The log files haven’t been very helpful other than showing the test server runs its cron more frequently (according to the Schedulers) and the production server runs it every hour.