Cron jobs Issue

I want to run a workflow using scheduler and for the run a cron.php file .
So I created a Task Scheduler in which
I gave path

Program\Path : c:\xampp\php\php.exe
Argument : -f “c:\xampp\htdocs\SuiteCRM\cron.php”

but whenever this task is running
it’s showing error
bad data passes in: return to homepage

I also tried to run cron.php directly on web browser
but it’s show
cron.php is only CLI
FATAL ERROR : uncaught error

I red your solution for this same and i tried that to but not helped
you said in that solution if you really want to run cron.php only on web browser then you can do this etc.

but I just want to run cron.php to run suiteCRM scheduler so workflow can run.

I hope you’ll understand my problem

For XAMPP, please start by turning off display_errors in your php.ini, and restart web server. Tell me if it improves anything.

nothing is changed it’s still showing same error bad data passed in;

Lines starting with a semicolon are comments, they are not taken into account.

You need a line with just

display_errors = Off

without a semicolon at the beginning.

By the way, what is your SuiteCRM version? And your PHP version? Is SuiteCRM running ok (apart from the cron jobs)?

Yes suitecrm working perfectly apart from cron jobs I customized adrep_report module and it’s working properly

Xampp v3.2.1
SuiteCRM 7.11.10
php PHP 5.2.0

and I edited that
display _error = off
without a semicolon at the beginning ( sorry for such silly mistake )
but it’s still showing bad data passed in.
i think I should check in cron.php file may be I’ll find some bug in it
but thanks for your support.

Thanks, @pgr

You’re using an unsupported (very old) PHP version, check that you install something compatible with SuiteCRM:

My Senior strictly told me to not to use any other version that’s why I am using this version.
I got success in modifying a whole module completely with the same tools.

Well, it’s impossible to get that working with the current SuiteCRM version.

Also advise your senior that that is a really bad option in terms of security, bug fixes, and performance.

I found solution.
we just have give relative path rather then giving absolute path.
Like ,

cd /D c:\xampp\php
php -f …/htdocs/SuiteCRM/cron.php

and cron run absolutly fine

Really - do not attempt to run SuiteCRM with a non-compliant PHP version.

It will break.

Maybe you got around this problem, but you will surely fall into others.

1 Like