cron Jobs check working

Hi All

Got my suite crm on a new webhost and installed. Cron jobs appear to be active on the server but they just don’t work in the scheduler.
My server shows the following

[root@server ~]# crontab -e -u apache

          • cd /var/www/html; php -f cron.php > /dev/null 2>&1

When I check the config.php file I get the following

array (
‘max_cron_jobs’ => 10,
‘max_cron_runtime’ => 30,
‘min_cron_interval’ => 30,
‘allowed_cron_users’ =>
array (
0 => ‘apache’,

Am I supposed to put in my admin user for SuiteCRM or do I place in the overall owner.

I get so lost with these cron elements.

Thank you!

Check your suitecrm.log

If the problem is with allowed_cron_users, you will see a message there saying it.

But the problem could be something else. Some servers need a full path to the php executable, for example.

You could also have cron.php executing correctly, but some specific cron job failing. If this was the case, you would see some jobs executing when you check them in Admin / Schedulers, “last ran successfully” times.

Finally, you need to set the correct timezone in CLI PHP for the jobs to trigger at the correct times. This is not the same php.ini as for the web server, it’s a second file. You can check your setting from the command-line:

php -i | grep timezone

And you can check your CLI php.ini path with

php -i | grep php.ini


Thank you for taking the time top help.

Checked my log and found no errors for allowed_cron_users or for cron.

No my job log in scheduled reports show no jobs have been successfully run.

When I type your commands into my server it does not recognise them it is bash. It is my first time really using such a program.


You need to find your PHP executable.


whereis php

and if that doesn’t give anything try this (which will take a while to execute):

find / -name php 2>/dev/null
1 Like


Thank you!!! I found the Crontab file and made the changes. Now it is working.