Created PDF template but still get the error: ERROR No templates found.Please go to the PDF templates module and create one

As the title describes, I’ve created a PDF template with the fields that are required, however, when I go to a record to print to PDF I still get the error:

ERROR No templates found.Please go to the PDF templates module and create one

Does the template need further work? What might I be missing?

Version 7.10.2

Sugar Version 6.5.25 (Build 344)

Have you created the template from the following link

and also are the already created templates are being displayed on the List View Page? AT this link

Yes - it seems that I am - I got to the PDF templates from the All dropdown.


There will be the issue with PDF Template module type assignment.
Have you set the “Type” value module to the module where you are trying to print?

So, for accounts records, you have to create the PDF template with the “Type” value to “Accounts”. So this template will then work for the account module records.


When you create the PDF Template you choose a “Type”. That has to match the type of the record where you’re trying to print from.

So if you create a “Quotes” template, it appears in the Quotes module when you try to print, but not under Contacts module, for example.

@pgr - that created the PDF export - thanks for that. However, I have a new problem - the PDF has the fields listed as the variable names in the PDF (i.e. they are not substituted with the records, but it has the field name). Should I start a new thread?

What type of record is it? And exactly which variable names are you using?

As far as I am aware (and I’ve not entered any of the records on this install) it is a contact of an individual.

The fields are listed as:


There are more, but that illustrates how they appear in the PDF.

I don’t get that “as far as I’m aware”… I meant you to tell me which PDF Template “Type” you selected, I’m sure you know that. And it’s also the module from which you’re calling up the “Print to PDF” function.

If it’s a Contact, it’s normal for those variables to be blank because the Contact record doesn’t have them.

Apologies - I wasn’t aware of what you meant when you said “what type of record is it” - I thought you were asking about the record that I was trying to produce the PDF for - not the PDF template. The PDF template type is “Contacts” - and the document that I am viewing (and clicking print to PDF on) is a contact and has all the other fields in that I have selected.

I will try fields from Accounts: Account ID.

Thankyou for your help.