Create Workflow Condition causes all sorts of UI garbage

Hello Suites (cheesy at best)

I’m evaluating SuiteCRM 7.11.10 on Centos 7 using Chrome 79.
I’ve installed the test data, defined some extra fields on Accounts and imported a few records into the new Accounts structure.

I’m now looking at defining a Workflow on Accounts : Only on save : Modified records
However as soon as I click the Add Condition, the following UI renders (which is not what the documentation depicts) and I think it’s not correct?


What about Suitesperts? ahah SuiteCRM & Experts. Na still cheesy :laughing:

Either way welcome to the Community @EugeneP :tada:

That’s a new one for me but i imaging there should be a simple fix for it.
As an admin user navigate to the administration menu then in to repair. From here run a repair and rebuild.

Once complete return to the list view and press F12 and right click on the reload icon, pressing the Empty Cache and Hard Reload option.

After completing this let me know if you are still having the same issues :+1:

Hi @Mac-Rae.

Thanks for the welcome.

As admin I ran Quick Repair and Rebuild : no errors.
DevTools Console & Empty Cache and Hard Reload : Many “Found ? elements with non-unique id” warnings

So maybe it’s a Chrome issue? However in FireFox 68 I get similar rendering but no warnings

So it must be related to my webapp instance and not the browser? Can I simply redeploy some PHP files?

Back in Chrome I get the following warnings, each of which relates to the jumbled controls in the Add Constraint panel.

Hello @Mac-Rae


I’ve also dropped the suitecrm database and removed the webapp.
I’ve reinstalled SuiteCRM afresh.

Yet I get precisely the same warnings in Chrome console and the incorrect rendering.

Any other thoughts as to what I can do to identify the issue?

Hi @EugeneP,

Just doing some testing the now an ill get back to you soon

  1. Could you try going the the system setting page and pressing on configure ajax.

  2. Drag reports from enabled to disabled.

  3. Check the issue again


Thanks for the assistance, but I cannot test it right now, but will do so as soon as I have PHP installed again.

I’ve removed PHP as I see in the Compatibility Matrix that PHP 7.3 (starting from SuiteCRM 7.11.5) is mentioned. Does this imply that 711.10 only runs on PHP 7.3?

PS : which PHP modules are needed?

This is how I do it on Ubuntu

apt install zip unzip iotop htop php-mbstring php7.3-mbstring php-gettext php-xml php7.3-zip php7.3-imap php7.3-gd php7.3-curl php7.3-intl php7.3-mysql php-gd phpmyadmin

The restart web server with
systemctl restart apache2

Hello all

Okay, got it working

On Centos 7, the default repo has a very old version on PHP, so I replaced it with 7.4 from the remi repo :
1 yum install
2 yum-config-manager --enable remi-php74 [Install PHP 7.4]
3 yum --disablerepo=* --enablerepo=remi* install php php-gd php-imap php-intl php-mbstring php-mysqlnd php-xml php-zip

Thanks so much to @Mac-Rae and @pgr for helping out on my first post. Very Suite of you! :smile:

1 Like

Oh god… the puns are strong with this one :laughing:

Glad to hear you got it working, I’m not sure at what level of compatibility SuiteCRM is with PHP74 at the moment so please let us know if you run into any issues.

Have a Suite day! :+1:

For those who might want to install 7.3 :

yum --disablerepo=\* --enablerepo=remi-php73 install php php-gd php-imap php-intl php-mbstring php-mysqlnd php-xml php-zip

As a matter of interest, the non-unique id warnings persist.

And below is a screenshot of the UI when a date field is selected. Clearly PHP 7.3 helped with the original garbled UI but it certainly did not solve it completely. Any subsequent date field does not have the hour and minute selectors, neither does the date selector open when clicked.

It seems that index.php is the common culprit :

In the webapp directory I have a sub-directory called cache (apache:apache 40775 unconfined_u:object_r:httpd_sys_rw_content_t:s0), but there’s no index.php?

I did a QR&R, and then most of the others, but none caused the index.php to be rebuilt.

@Mac-Rae / @pgr How do I fix this missing index.php?

I also get the following error in suitecrm.log :
Sat Feb 15 11:05:09 2020 [29488][1][WARN] CSS File Dawn/yui.css not found
Sat Feb 15 11:05:15 2020 [29217][1][DEPRECATED] Array

There are no errors in php_errors.log

I tried this Workflow on my test system and the date pickers show up fine. Does the same happen to you in different browsers?

Some of those errors you mention, never mind them:

  • CSS File Dawn/yui.css not found
  • [DEPRECATED] Array
  • non-unique ids

About the 404: yes you do need to get that fixed, but its probalby not a matter of going looking for index.php, almost everything in SuiteCRM goes through that entrypoint, none of it would work if that file wasn’t there (it’s on the root of SuiteCRM installation).

Exactly which web server are you using? I would look into .htaccess issues, or SELinux issues.

Thanks @pgr

I’ve resolved the 404 with :
echo “<?php” > cache/index.php
chown apache:apache cache/index.php
chmod 775 cache/index.php

It seems that the content doesn’t matter as long as the file is there?

Yes the same happens on FireFox

Anyhow, I’m going to move on from here and assess other aspects of SuiteCRM. I trust this is an exception and will get to love SuiteCRM. Thanks for your help.

I fear you will run into more problems, your installation still doesn’t look healthy… that error really shouldn’t be happening… :frowning: