Create Person Form


Seeking to link contact us page to lead, or create person form functionality.

  1. Initially followed the steps in “Create Person Form” menu choice in Campaign. Or copy and paste the html below into an existing page

The result was a blank form page

  1. Second time around, prior to saving web form copy html and it works

The form defined in Suite CRM pops up, great. But then after submission states: not a valid module directory

It is pointing to

  1. So proceed to download form a third time. Cut and past html, and I am right back to getting a blank contact form again

Latest web to lead code is attached. Any assistance would be great.

Addendum to the above sorry, I am on the latest Joomla 3.5.x and Suite 7.6.x

  1. Took html and form shows up again. Submit test data on form and get

Not a valid module directory. I presume it is related to this line code below, but what is the fix?


I notice 35 views for this topic, but no response ( in 5 days). What is usually the response time from SuiteCRM experts in this forum? I ask not to be bold, but to know out of curiosity.


I tried testing your form with the same results you obtained.

I also tried modifying WebToPersonCapture to WebToLeadCapture and the result was a blank page with the following message:
“We are sorry, the server is currently unavailable, please try again later.”

Maybe your DB is down. However I suggest that you check that your server is up and running correctly and then try yourself by modifying the line:


I never use this functionality, i create my own form.
Maybe missing :



I am beginning to feel the same way. I will review the code as noted. Plus siteground host suggest the issue may be in the code.

I will review integrating joomla and suitecrm via form as well.


DB is not down. Modifying the code simply change error from no module to server down.

Went with Joomla form add-on and gain same results, similar to host their support suggests an error in the code such as possible wrong user id or campaign. Both are correct, at least near as I can tell.

Yet, I seem to be the only one with the issue. I will explore my web site maker Joomla, re: HTML, blank to see if I missed something from their side.But I am pretty sure that this is a SuiteCRM issue, if anyone from Suitecrm can help


try remove this :

<div class="col"><label>Account Name: </label><input name="account_name" id="account_name" type="text" /></div>

And try simply with last_name field (this field is required).

And too, you must give log file (suitecrm.log and php error file)


I appreciate the suggestion.

With the web to lead form, I generated within SuiteCRM over a dozen forms including suggestion to do so just with the last name.

I investigated Joomla’s potential to strip HTML and can confirm this issue is not relevant here.

My host for Suitecrm, siteground has been great in supporting my issue here to a point. From what I can understand this issue is with SuiteCRM and the code it generates for me is faulty

To reiterate I get:

Not a valid module directory

The sugar and php files are attached

Ssugarcrm.log is empty, but previously displayed other SuiteCRM errors in setting up users. The and ph_errorlog displays a third SuiteCRM issue that I am having setting up email within SuiteCRM. Both may issue with file permissions, given that SuiteCRM is hosted on a shared server. And this may somehow be related to my webtolead topic.

Googling is not much help and I understand that the SuiteCRM experts are busy.

Googling WebtoPersonCapture does lead you to Githup, where I compared the following files below to what I have on my website for SuiteCRM. They don’t match but matching them does not remove the error.


How or where else can I gain assistance in resolving this issue?

I see in : modules/Campaigns/WebToLeadCapture.php
Some requirement fields like :
Campaign_id, status of campaign = active, and too redirect_url or redirect : else we got a error message : LBL_SERVER_IS_CURRENTLY_UNAVAILABLE

Maybe this


I checked and did create the campaign prior to creating the form. Assigned the campaign in creating the form. So as far as I can tell this is not the issue.

I don’t know enough about HTML to understand the logic that leads to error message, except to say that everything seems to be there in order to generate a submission of lead into my CRM including campaign.

Why it goes to module not recognized remains unknown to me.

And for such as simple integration, I am a bit disappointed that it cannot be resolved any faster.

Hi everybody,

I have created and downloaded a webform and it works fine (new lead properly created on submit :slight_smile: ).
Though, I cannot find a way to re-edit the form I have created? (something like: view person forms), I only see the associated campaign in “view campaigns”).

Is there a way to locate a person form and modify it?

Thank you in advance for your kind and prompt reply.


Hopefully this has long been resolved for you, but I recently, as in today, ran into this same issue.
I resolved it after discovering that the form code that Suite generates was apparently not aware that it is running on a secured (HTTPS) server, and therefore the Form Action URLs in the code were HTTP instead of HTTPS.
Once I noticed this and added the missing “S”, the form is posting fine and adding leads.

Hope this helps.

1 Like

I’ve just found a solution for this:

You have to pass an extra required field to WebToPersonCapture:

id=“moduleDir” value=“Leads”

Hope this helps.

More than 3 years after, this helped me to put the WebtoPerson in the works.
Thanks for the tip… :blue_heart:

That missing “s” in “https” is probably coming from your config.php, look for a key called host_name and another called site_url

1 Like

Totally possible, because the https came after the initial set up. I´ll check it up to night if possible. Thanks @pgr!!

Went for it the sooner I could. Indeed, there where a lost “s” in the site_url also the whole “https://” in host_name.
Thanks again for the tip @pgr !

1 Like