Create Meeting / Call from within a Contact / Lead record

It seems the only way to log a call or schedule a meeting that relates to a contact / lead is to hit ‘create’ and then ‘lead’ and then you have to fill in the ‘related to’ field.

Is there not a way to open a contact or lead and then from within the contact / lead record click ‘log a call’ or ‘create meeting’ etc. ?

Am I missing something? Or is there a way to make this functionality available?

Thanks,

Mike

Hey Mike

Was searching for this yesterday and posted on this thread
https://suitecrm.com/suitecrm/forum/suite-themes/19147-activities-panel-contact-layout

I think the functionality is already there against the lead/contact but you have to scroll down below the contacts to related objects, expand then click create task for the in page form to appear.

I think it comes back to the theme record layout
/themes/SuiteP/include/DetailView/DetailView.tpl

*Note I am new to SuiteCRM
My thinking is we need a means of changing the layout, 2/3 layout contact details on the left, 1/3 activities module on the right (expanded).
Thus a little logic to change the CSS for specifically Leads/Contacts/Accounts modules and specific logic to show just the activities module in the new 1/3 left div

I can’t find any other option other than to create a basic task.

You can’t differentiate between a Call, a Meeting, Etc.

Am I missing something?

Zeckrin I think you’re using a version with a bug that was already fixed. Upgrade to the latest in your branch.

I upgraded to the lastest version. I am now on 7.10.5

This is still what I see for adding tasks:

When I click task I can change to “Full Form” but I still cant actually set a meeting from this form.

What do you see? Are you able to “Create Meeting” from within a Lead?

Thanks pgr

Sure, I can:

The “Compose Email” looks a bit funny, but the buttons are all there. You can try it yourself in the live demo:

suitecrm.com/demo

Do you have any customizations that might be messing up your installation?

Have you disabled modules in Admin / Display Modules and Subpanels, or via Security Settings?

Thank you. That’s exactly the function I need but I can’t figure it out…

I tried adding back all subpanels but still same result.

Do you know which exact subpanel or module you need? Or what you would do to hide this?

I think you are definitely in right direction because I have done customization but I dont know what change could have caused this.

Here are my current panels / modules:

You know these messages that come up in the upgrades sometimes, like this?

Upgrade process will update some files but these files also exist in custom/ folder. Please review the changes before continuing:

    themes/SuiteP/themedef.php => custom/themes/SuiteP/themedef.php
    modules/Home/dashlets.php => custom/modules/Home/dashlets.php
    modules/Accounts/language/en_us.lang.php => custom/modules/Accounts/language/en_us.lang.php
(etc...)

You probably got one of these, and ignored it… you likely have files in your custom directory that are keeping the core files from taking effect. Since there have been changes to these, now it’s breaking.

I think you need to try removing your customizations one by one, just as a test, to check if at some point the buttons appear again. Then you will know which file is conflicting, and you can remake your customization starting from the new version of the core file, and manually moving your changes into it.

Of course, this is just a theory, a possibility, I might be wrong and the problem could be something else…

So to prove this out I renamed my Custom folder Custom.off and then ran a repair.

My customizations were gone but I still did not have those task options.

Is there anything else I can try? Or any customizations in the system (not in the Custom folder) that could cause this?

Thanks for bearing with me… :slight_smile:

Ok, I have more of the puzzle.

For some reason when I when I edit the subpaneldefs.php file in my leads modules, whatever module I place at the top of the list for buttons to show shows. The other three do not. So for example see here:

Under Activities you now only see “Schedule Meeting / Study” whereas before you could only see “Create Task”.

I played around and found that whatever I put at the top of that group of ‘top_buttons’ will show but none of the others will.

Is there something wrong with the formatting? I also downloaded the same package and replaced this file and am getting the same results.

Do you get different results with a different browser?

Have you tried several of the Repairs in Admin / Repairs? Anything related to javascript.

What do you see in your logs? suitecrm.log and php_errors.log