Corrupted PDF on when saving PDF


I can open it in my browser, but it does not work if I download it and open it through Adobe.

I opened it with Notepad and it showed a whole bunch of errors - mainly
“Illegal string offset ‘ID’ in /modules/AOS_PDF_Templates/PDF_Lib/classes/cssmgr.php” - a few different lines line 1322, 1236, 1610, 1614 and 1248 - repeated 4-5 times each.
“A non-numeric value encountered in /modules/AOS_PDF_Templates/PDF_Lib/mpdf.php”
this is the line $size *= (25.4/$this->dpi);

I have checked and my php.ini has errors off, I’ve run composer. I checked GitHub and made the changes to modules/AOR_Reports/controller.php (

Any other ideas?

For others in a bind - my work around is to open it in the browser and print to PDF from the browser. But this is not an ideal, long-term solution.

If you go in Admin / Diagnostics and download phpinfo from there, does display_errors show an effective value of false?

hmm…it shows On for local value but off for master value

While you’re there, you can check the exact path of your php.ini to ensure you’re changing the correct one. Don’t forget you need a web server restart in order to make changes effective.

Try to get that local value to show as Off too.

This is a similar issue I’m having with the timezone change - I have a ticket it in with my host to update it. I don’t have access to the php.ini file it refers to. Their first response was to put a php.ini file in the root directory (which is already there) but it still looks to be drawing from the server. I also cannot restart the server.

Getting proper control over some php.ini settings is crucial. Also, being able to see what’s happening in both your logs. Some of the issues you’ve been talking about in other threads would surely be solved with insights from php_errors.log…

I did a backup restore and both local and master are now off. I must have changed something inadvertently that caused the issue.

So after a few days, the Local reverted back to On while Master says Off. I’ve checked my php.ini file and it says off. Does anyone know of any reason this would happen?


I had a line near the end of my .htaccess file that turned it back on… :woozy_face: