Compound action widgets behaving erratically

Apologies if this has been posted elsewhere, but I could not find anything exactly matching this problem. On many subpanels there are “compound” action widgets, i.e. the main part of the widget is labelled “Create” or “Edit” etc., and the right-hand part of the widget has a triangle which you can click for a dropdown-list of other actions, e.g. “select”. All well and good, but this right-hand section of the widget seems to appear and disappear randomly. I cannot find a discernible pattern to this behaviour in most cases, but one situation which I can reproduce is shown in the attached screenshots - the first shows subpanels from the “Cases” page immediately after loading (right-hand part of the widgets missing), and the second shows it after I have presses ctrl-r to refresh the page (right-hand part of the widgets now appears).

I am running SuiteCRM 7.4.3 (PHP and MySQL versions currently preclude updating).

Ouch! It seems that I caused this problem myself by customising a label and putting a “/” character in it - this subsequently seems to have caused a piece of javascript to fall over and fail to update the remainder of the page correctly.

My fault up to a point, but surely the application should be robust enough to handle any reasonable character within a label?

Well maybe you just found it needs to be made more robust :slight_smile:

You could help by going into this demo and trying to break it in the same way:

This will tell us if the problem is already fixed in the latest version, which is quite possible.

If it isn’t, then I guess we should file a bug. Can you tell me exactly the label changed, and the label’s contents?


1 Like

Thank you for the rapid response. Yes, I have just tried it on your demo system and got the same result - I set up a couple of accounts and linked contacts, and all fine. Then I went into Studio and changed the LNK_NEW_NOTE label in the Notes module from “Create note or attachment” to “New note/attachment” (to save a little space). Then when I went back into an Account detail page, all the subpanels up to “Notes” were fine, but in all subsequent subpanels the “Create” button was missing the right-hand bit. I changed the label back again, and when I went back to the Account page, the subpanels were again all showing the correct compound widget with “Create” on the left-hand part and the “triangle” dropdown on the right.

Thanks Tom. Could you please open an Issue describing this with detailed “steps to reproduce” on GitHub?

Thankyou, pgr. Took me a while - I am new to GitHub - but issue has now been raised as requested

1 Like