Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Completed installation and show error JQMIGRATE: Migrate is installed, version 3.3.2 net::ERR_ABORTED 404 (Not Found)

I completed the install SuiteCRM8.1.0 follow here but show an error JQMIGRATE: Migrate is installed, version 3.3.2 net::ERR_ABORTED 404 (Not Found), If keep like that it affects to the system or not? how to solve this problem,
thanks

Hi @rithsila !

Those errors look like 404 errors. 404 errors are those that say they tried to retrieve that webfile (which is expected in the SuiteCRM instance) and couldn’t because it was either not there or the web server didn’t have permissions to access it.

I can count 4 404 errors all highlighting that legacy/cache/jsLanguage is not there or can’t access it. My first reaction would be to correct my file permissions for the instance to ensure that all files are correctly accessible. I believe you can find how to do that via the documentation site. Downloading & Installing :: SuiteCRM Documentation
But I assure you that this is usually a small error, and it usually happens on new builds/upgrades because the system is re-building it’s cache files.

The other issues like [DOM] etc is not of concern and more of highlighting how to improve the codebase.

Hope that helped.

thank you for your help I will try to fix it, by the way, what happens if not fix that problem?

Usually that file (across multiple modules) store the label’s for fields for quickness (hence being the cache folder). If the problem is not resolved then some of your labels for fields/dropdowns may appears as UNDEFINED/undefined. I can see in your screenshot that has already occurred next to User Type

I found the solution at here we change the config in .htaccess .
----------------------------------------------------------------------new config
RewriteEngine On
RewriteBase /Tsystem/public/legacy/
RewriteRule /cache/jsLanguage/(……).js$ index.php?entryPoint=jslang&modulename=app_s$
RewriteRule /cache/jsLanguage/(\w*)/(…
…).js$ index.php?entryPoint=jslang&modulename$
----------------------------------------------------------------------old config
RewriteEngine On
RewriteBase /Tsystem/publiclegacy/
RewriteRule ^cache/jsLanguage/(……).js$ index.php?entryPoint=jslang&modulename=app_strings&lang=$1 [L,QSA]
RewriteRule ^cache/jsLanguage/(\w*)/(…
…).js$ index.php?entryPoint=jslang&modulename=$1&lang=$2 [L,QSA]

That’s great you found a solution.

It’s related to this issue I believe, but it would be fabulous if you were able to add your detail/experience of the issue to the bug report to help the team.