Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Clicking links in popups sometimes fails

SuiteCRM Version 7.11.20 with Sugar Version 6.5.25 (Build 344)

FYI - this is on a Plesk server. A previous and abandoned attempt at installing SuiteCRM due to similar issues was followed by installing the older SugarCRM that is included with Plesk, but then learning that Rackspace had messed up my FACLs, which they fixed. SugarCRM is currently working correctly, but this may still be a Plesk issue.

Not sure if this is just related to AOS Quotes because that’s where I’m primarily working …

I click the arrow button to select a Lead, or click to add a product. I get a popup to allow me to search and select. I find the right one, click the link, and most of the time it works and inserts the data into the quote.

But sometimes the click does absolutely nothing. I keep trying, and eventually it will work.

I’ve checked file permissions - all look well, and I have a cron job setting permissions on the cache folder every 2 minutes just to be safe, but sometimes it takes as much as 5 minutes and many attempts to get this to work.

I’ve checked file permissions in the config file - does this look right?
array (
‘dir_mode’ => 1533,
‘file_mode’ => 493,
‘user’ => ‘primarydomainaccount’,
‘group’ => ‘psacln’,
),

“primarydomainaccount” is actually the user that has (almost) full permissions to everything - this is how I got SugarCRM to work. Apache:Apache didn’t work right on Sugar, but I haven’t tried it on SuiteCRM.

I ran the diagnostics tool on both SugarCRM and SuiteCRM. Sugar only reported an issue with the log, but SuiteCRM reported the following:

DynamicField is not an index in $beanFiles
Connectors is not an index in $beanFiles
Version is not an index in $beanFiles
CustomFields is not an index in $beanFiles

Could this be a vardef issue? Or beanfiles? I’m not really familiar with how either of these work.

ANY suggestions really appreciated - I’d really like to get off that old Sugar and start using SuiteCRM!

Hey there,

Have you found a solution for this, by chance?


I would recommend comparing your environment to the compatibility matrix:

Does your Plesk server meet all of the requirements for 7.11.x?


From the info that the Popup occasionally works, it sounds like it might be timing out
(Perhaps on the Server-side?)

Do you have any server-level logs from around the times that it fails, to know if the Server was stable during those times?


For the config permissions, I believe we have previously recommended:

‘dir_mode’ => 1517,
‘file_mode’ => 420,

and the User/Group values should be the web-server user, and their group.
(ie, www-data by default on ubuntu)

However, if your current permissions is working, then feel free to keep as-is


Lastly, if you have access to either the PHP Error Log or SuiteCRM error log, it would be worth checking these too, to see if anything shows at the time when the Popup fails