📣 We're Hiring!

Choose Targets Campaigns error last step

Hello everybody.

I installed version 7.10.5 SUITECRM, I updated to version 7.10.6 and the same thing happens.

I created a new campaign with “LAUNCH WIZARD”.

You can see in the attached image that I have previously selected “Target Lists” and that there is 1 target.

imagen1

But when I get to the final step, everything is correct except Choose Targets.

imagen2

If I click on “Choose Targets”, it is empty although in the step of “Target List” I selected it.

Now appears empty and to the left appear other “Target Lists” that do not know where.

imagen3

Can someone give me some help?

Thanks

I tried it in the official demo and it works so there must be something wrong in your installation.

To try to figure out what’s wrong:

  1. Have you set permissions PRECISELY in the way it is described in the Installation Guide BEFORE installing/upgrading the system? Did you do it also AFTER?

  2. Please che your error logs at the moment your error occurs:
    . SuiteCRM error log (found in the root folder of SuiteCRM)
    . PHP/Apache error log (the postition depends on your system)
    . Your browser javascript console
    Then report errors here.

The problem newsletter campaign, the rest of campaign types is ok

How can I add an image, it will not let me

Add File not work

To show the error

Thank you

You can add images here:

https://pasteboard.co

The error is when you create a newsletter campaign with both version 7.10.5 and 7.10.6

1st Launch wizard -> step Target Lists -> select Target

2nd Next step Templates, back to step previous, loses the target list and appears in the list of new target lists that I have not created.

3º In the step Send Email and Summary, as it loses the target lists, Choose Targets with red blade

OK I tried it in the official demo with Newsletter type.

It is clearly a bug as you highlighted.

  1. If you navigate back no target list remains selected.
  2. However if you exit from the creation of the Campaign and go to the list view, then select the campaign, in Edit view all available target lists are selected.

This a very dangerous and nasty bug!

Could you please post it in gitHUb?

Thanks!

I’ll do it, but do you correct now or until I’m on github do not correct it?

Sorry, I am not from Sales Agility. I am sure that they will consider the issue and correct it as soon as they can.

In the comments you should say that this is a critical issue because if one does’t realise the problem he may end up sending a newsletter to all atrget lists created in the system and this is really unwanted and against GDPR!!!

Added on github:

Issue #6025

1 Like