Changing logo only shows broken image symbol


when changing the logo with the select logo button under admin>system settings> user interface tab I can sellect the new logo and upload it correctly. It will show up in the preview but on the login page it will only the alt text. Alternatively going back into the system setttings under current logo it displays $mod_strings.LBL_LOGO. Ive tried every format (including 1x1 files) and even tried uploading the older file. Ive also tried deling the old file directly in the custom/themes/default/images tab under company_logo.png but to no avail.

Does someone know how to fix this issue?

Kind regards, Jorn

can you check your webserver’s logs? also check your file permissions on what system do you have?

best regards

looking into suitecrm.log I can only find Tue Nov [19144][1][FATAL] ERROR: rmdir_recursive(): argument cache/themes/Suite7/modules is not a file or a dir.(this is the only line in the log just repeated a few times).
Im not that familiar with suiteCRM yet, how do i check file permissions? Its running on the webhost where we also run our website. The host is not dedicated so I dont have acces to the php dependencies unfortunatly.

check this post you should talk to your hosting provider and ask them for help

best regards

so if i understand corretly you suspect that the application does not have proper permissions on the hosting provider which causes it not to be able to change the file?

I have FTP acces though and have tried edditing it manually, to no avail either so I do not understand whats going wrong.

yes, it depends on your hosting provider sometimes is better to tell them the permissions you need from to the documentation in that link I gave you

best regards

Ill see if they can help me out by performing the bellow. Ive contacted the host, thanks for your support and ill keep you updated if this fixes the problem :slight_smile:

4.Set ownership of the SuiteCRM directory: 1.chgrp ApacheUser.ApacheGroup -R recursively sets ownership for root directory to Apache user and group.

5.The system user that your web server uses varies depending on your operating system. Common web server users are as follows: 1.apache (Linux/Apache)
2.nobody (Linux/Apache)
3.IUSR_computerName (Windows/IIS)
If you are unsure how to set your web server user on your operating system, contact your web server host. If you are installing SuiteCRM locally and need assistance, visit our support forums.
1.Set the following permissions on the SuiteCRM directory(Linux): 1.sudo chown -R www-data:www-data .
2.sudo chmod -R 755 .
3.sudo chmod -R 775 cache custom modules themes data upload config_override.php

1 Like

This works, the image can now be edited properly. I’ve run into a new problem though. WHen trying to add dashlets on any tab it just gives me the loading screen and will not do anything after. This means i cant add dashlets. Any input on sollutions or how to reset them?

you need to take a look at the logs, suitecrm’s logs, webserver’s logs and browser’s logs

best regards

1 Like


This is the error i encounter, looks to me like a syntax error? I’m in no way a java developer though so I’d have no clue on how to tackle this, I can find and open the responding files but I’d have no idea what to look for