Changing a Create Date

I just imported about 300 opportunities into SuiteCRM from Excel.

Some create dates are wrong (2018!!!). Although my XLS spreadsheet has the correct dates!!!

What can I do to change these? I get that the edit view does not allow so.

What are my other options (I do not want to delete and reimport).



Hi, Workflows are your friend!

I would use a workflow like in my screen dump image, where basically you want to condition on opportunities which are ahead in time.

Then as an action, modify the date created to whatever you want ! :slight_smile:



Wow, thank you introducing me to workflow. Best thing in the world (almost).

I have done what you suggested. I see that the workflow has run as per Process Audit where is shows the modification I requested.

However, on the opportunity layout, the original 2018 date is still there.

What am I missing ?


i have tried the workflow out myself and have also tried a mass update of records but i have ran into the same problem as you!

Could you describe the issue you first came across with importing your opportunities? Version of SuiteCRM, OS, if you could -> column headers of the Opportunities of the XLS.

Have you tried deleting all the records and use a CSV version of the spreadsheet instead?

Let me know how you get on

Opportunities were imported with a CSV file. Weird thing is that most creation dates are OK. Only some odd ones here and there.

Running SuiteCRM Version 7.5.3 Sugar Version 6.5.23 (Build 1061)

I’m having the same issues importing Leads from CSV file in v7.6.4.
I have my date setting as 23/12/2010, also the CSV is in this notation.
During import the day is switched by the month!
If the day is > 12, i.e. 18 then month will 6 and the remaining 12 will add 1 year.
A date like 18/07/2016 will become 07/06/2017 after import!
Looks like a bug to me.
The workflow can correct this date, but I don’t get it to work. I made a new workflow like in the image from DarrenTang, with condition and action for Leads, saved it. But then will this run automaticaly, or do I need to start/enable the workflow somehow?

There is a date format setting while importing, under the button Show File properties. It is not related to the systems date setting.
choose the right date there, to correspond with the date format in the CSV file.

We are curious to see if there has been a solution to this:
ran into the same problem when importing leads from a CSV file
Now quite a number of these have creation dates in the future (2021 and 2022).
The idea to use the WORKFLOW module is nice, if it would work.
Why is the CREATE DATE record not modified through this step?
The LEADS List Views shows all CREATE DATE entries with the same (wrong) values as before …

:point_up: have you tried this? You shouldn’t get an import with wrong dates in the first place.

Have to admit I saw this too late.
Still, as the Leads now are in I cannot delete them only to get a date corrected.
So, why is the record not modified with the Workflow approach?

I would recommend trying to fix that from the database using SQL. Workflows are bound to be slow and bring you technical limitations.