Cases Module - Charset Problem


We are using Version 7.9.4 . In cases module when you enter some unicode characters like çÖŞĞÜİ it shows only strange characters. Everything is set to UTF-8 but we are still facing issues.

It shows incorrect characters on detail view. However in edit view everything seems to be correct.

try implement this fix: :slight_smile:

Hi, I have the same problem since updating to “security update” 7.8.6

I tried the above mentioned fix and exchanged the SugarFieldHtml.php file with the new one but it does not change anything - still all UTF chars only show as “?” in a black rectangle. Any help available?

(I did quick repair and rebuild, of course)

kind regards,

Dear Camo,

I’ve changed the file but the result is same. Also if there is some unicode character in case details, you can not even go inside of the case. Seems to be Ajax can not show unicode chars.

Screen Shot:

So you need to go to Admin > System Settings > Configure AJAX User Interface > Disable “Cases” Module. In order to see Cases with unicode characters. But as you can guess it doesn’t fix the issue and I see strange characters.

Screen Shot:

yes I had the same error with Ajax so after the patch I could not list my cases at all, I had to disable Ajax for the cases module alltogether.
I did not mention it before since I did not think this was related, but both issues are quite annoying.

I will never install any short-released “quick fixes only” releases again, lession learned!

I hope somebody can find a reason and remedy for this character issue.

take care,

I have no idea if fresh install of 7.9.5 will solve all these issues. Apparently not.

Dear Camo can you please tell us how can we solve this issue? Since provided fix didn’t help at all.

I have the same problem with suitcrm 7.8.6.
If i disable ajax for this module, i lose all my spécial caractere.
Of course i also do a quick an repair.

best regards

We are having this problem since 7.7.x or may be 7.6… now with 7.8.6 LTS same problem continues
This is very annoying because it breaks other modules…

if you build a report having those characters in and try to save to pdf the report it will corrupt the report definition and will stop with an error… no pdf of course…

@ all the others reporting the same problem could you confirm if you are running MSSQL or MySQL
… in my case I am running MsSQL and I think it might be related because my collation is"SQL_Latin1_General_CP1_CI_AS"

… also are you running IIs or Linux? I am running IIs…
I wonder if it is related…

It’s not even related with SQL collation. I’m running SuiteCRM on Linux and MySQL. I’ve tried almost every collation but it didn’t help. Perhaps it’s better idea to create bug report on github since nobody seems to be using this forum anymore.



So this is helping us to steer the debugging in the right direction…

BTW for those MSsql users… I looked in the code and the UTF-8 parameter is hard coded… (which was I was looking for… it is GOOD having this)
see lines 171 to 178 of “SqlsrvManager.php”
$options = array(
“UID” => $configOptions[‘db_user_name’],
“PWD” => $configOptions[‘db_password’],
“CharacterSet” => “UTF-8”,
“ReturnDatesAsStrings” => true,
“MultipleActiveResultSets” => true,

Nobody ever reported on Github?

Any news on this? I am now upgradet to php7 to really sort out any issues that might be php related but the error continues. Either Ajax on and Ajax display error - completely unusable - or Ajax cases module disabled and special chars only showing as dark dotted picture placeholders.


kind regards,