Case Updates not working

Hi There,

When updating a case from any user in Suite CRM 7.10.4 it always shows “undefined”

Even on email notification, it shows “undefined”.

Please help!

“undefined” shows where? Screenshot please.

And do you see other “undefineds” in other places in the app?

Do you have anything in your logs? Check both suitecrm.log and php_errors.log

Also check any errors in your browser’s developer console when you update the case.

1 Like

I don’t’ know something is wrong with this forum as well. I’m unable to attach any image. The Add file button is doing nothing.

My Log says following.

HTTP/1.0 500 Perl execution failed
Server: MiniServ/1.881
Date: Wed, 30 May 2018 18:59:30 GMT
Content-type: text/html; Charset=iso-8859-1
Connection: close

Error - Perl execution failed

can't open /var/www/html/var/www/html/suitecrm.log: No such file or directory at /TEMP/webmin-1.881/filemin/download.cgi line 27.

See this

https://suitecrm.com/suitecrm/forum/suitecrm-7-0-discussion/16012-file-attachments-having-problems-attaching-files-to-posts-on-this-forum-solution

if it doesn’t work, use

https://pasteboard.co

I can’t understand your logs, it doesn’t look like your logs at all. You’re getting something else.

here you go with the screenshot of what I’m getting.

https://pasteboard.co/HnC9v7S.png

Regarding Logs.

I sent you all that I found in suitecrm.log file.

Any response on this, please?

Those are not your logs, that’s a webmin error when webmin is failing to get your log file.

I need the contents of your log file at the time of the displaying of that screen with errors.

And don’t forget your browser’s developer console, there might be javascript errors there.

Hi, Thank you for the reply.

Here is the screenshot of Browser’s developer console.

https://pasteboard.co/HnJEX8Eo.png

and here is what I found on Log file.

Sat Apr 7 15:22:25 2018 [26916][-none-][FATAL] Could not connect to DB server localhost as suitecrm. port : Access denied for user ‘suitecrm’@‘localhost’ ($
Sat Apr 7 15:22:37 2018 [26908][-none-][FATAL] Could not connect to DB server localhost as suitecrm. port : Access denied for user ‘suitecrm’@‘localhost’ ($
Sat Apr 7 15:28:20 2018 [26911][1][FATAL] ERROR: rmdir_recursive(): argument cache/themes/SuiteP/modules is not a file or a dir.

Please let me know! Thank you

Any luck please?

Those errors are from April, you should be looking for errors at the time when the screen shows with “undefined”…

Please try a few repairs from Admin / Repair:

  • Quick Repair and Rebuild
  • anything javascript related

Then try also on a different browser to see if it works there.

1 Like

I tried Quick Repair and Rebuild. But seems it is same no change.

I’ve also tried on a different computer and different browser but the issue remains there.

her is what I have from my log.

I do not see any log of the time when I update the case with text. But I see this there which shows FATAL from the task.

This is another issue I’m facing with Task. In my report tasks are shown twice one with created by and another with a different account but Task ID is same.

LOG

Thu May 31 13:33:08 2018 [26703][1][FATAL] Exception handling in /var/www/html/include/MVC/Controller/SugarController.php:402
Thu May 31 13:33:08 2018 [26703][1][FATAL] Exception in Controller: Database failure. Please refer to suitecrm.log for details.
Thu May 31 13:33:08 2018 [26703][1][FATAL] backtrace:
#0 /var/www/html/include/database/DBManager.php(353): sugar_die(‘Database failur…’)
#1 /var/www/html/include/database/DBManager.php(328): DBManager->registerError(’ Query Failed: …’, ’ Query Failed: …’, true)
#2 /var/www/html/include/database/MysqliManager.php(167): DBManager->checkError(’ Query Failed: …’, true)
#3 /var/www/html/include/MassUpdate.php(239): MysqliManager->query(’ SELECT did_di…’, true)
#4 /var/www/html/include/MVC/Controller/SugarController.php(780): MassUpdate->handleMassUpdate()
#5 /var/www/html/include/MVC/Controller/SugarController.php(523): SugarController->action_massupdate()
#6 /var/www/html/include/MVC/Controller/SugarController.php(491): SugarController->do_action()
#7 /var/www/html/include/MVC/Controller/SugarController.php(465): SugarController->handle_action()
#8 /var/www/html/include/MVC/Controller/SugarController.php(373): SugarController->process()
#9 /var/www/html/include/MVC/SugarApplication.php(109): SugarController->execute()
#10 /var/www/html/index.php(52): SugarApplication->execute()
#11 {main}
Thu May 31 13:49:12 2018 [29271][ab0c3164-9d5c-ba18-2510-5af097be321b][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Thu May 31 13:51:17 2018 [29282][ab0c3164-9d5c-ba18-2510-5af097be321b][FATAL] could not load RHS in Task
Thu May 31 13:51:18 2018 [29282][ab0c3164-9d5c-ba18-2510-5af097be321b][FATAL] could not load RHS in Task
Thu May 31 13:51:19 2018 [29282][ab0c3164-9d5c-ba18-2510-5af097be321b][FATAL] could not load RHS in Task
Thu May 31 13:51:20 2018 [29282][ab0c3164-9d5c-ba18-2510-5af097be321b][FATAL] could not load RHS in Task

Did you do also the other repairs? And “repair relationships”?

While you have an “database failure” in your logs, it’s no wonder SuiteCRM doesn’t work… you really need to get to the bottom of that and fix it.

What should I do to fix Database Failure?

You need to read my posts carefully, and if I ask you to try 3 things, please try all of them before replying back, and tell me about it, so I can move on to further suggestions without doubting that you really tried the previous ones…

1 Like

Hi There,

I tried all other repairs and quick repair as well but the issue is there as it is.

Let me know what can I do? I’ll do it exactly as you want and will get back to you.

Thank you

Just read the previous posts and scan them for my suggestions. Then try things, and report about them explicitly here.

So you would say:

  • I looked at suitecrm.log and this is what I found (you already did this)
  • I looked at php_errors.log and this is what I found
  • I did the relationship repair
  • I did the javascript repairs

etc

I know you must have started to hate. But I’ll keep bothering you. When I post here Somehow I feel the help will come to that thing make me relaxed and finding the solution is easy.

Thank you for your help again!

I got the solution to this problem.

I don’t know how there were 3 custom fields created is cases module. ending with _c. I removed those field which was duplicating account user and contact.

After a quick repair, the update started to work perfectly again.

Thanks for the help again.

:slight_smile:

No, I don’t hate any one, and I am a very patient guy answering Forum posts. Not infinitely patient, but quite patient :slight_smile:

I’m glad you solved your problem!

1 Like