Case updates not saving

After upgrading to 7.3 we have noticed that it is not saving your update if you go to the Account page and then click the Edit button to the right of a case, then type information in the Update box and press Save. It does save your update if you go to the Account page, click the Case subject web link, then type in the Update box and click Save.

Any ideas?



Hi Tom,

The Edit button to the right of a case works fine for me. It simply saves the update and reloads the Account Record. If I open the relevant Case through the Module It includes updates done through both of the processes you have described.

If you have not set permissions or done a Quick Repair and Rebuild since upgrading, please do so.

Maybe I’m not looking in the right places but as far as I can tell, everything looks correct. I’ve learned from past updates about the Quick Repair and Rebuild and do that as a first step after an upgrade.

Can you “help” me find where I should be looking for the permission settings (already looked at Security Suite Settings for the Role and all the Case items are set to enabled except delete, import, export, mass update: if this is even the correct area)?

BTW: I’m running on Windows Server 2012 if that makes any difference.




Could you please check the config.php file?

There should be a section that looks alike:

 'default_permissions' => 
  array (
    'dir_mode' => ",
    'file_mode' =>",
    'user' => '',
    'group' => '',

These settings may differ depending on your setup, but we recommend you change it to:
dir_mode set to 1517
file_mode set to 420
user set to the Owner of the SuiteCRM directory, this could be your Windows username depending on your setup.
group set to the user’s group.

For example, since we use a Linux setup, the user and group will differ, but it should look similar to:

'default_permissions' => 
  array (
    'dir_mode' => 1517,
    'file_mode' => 420,
    'user' => 'www-data',
    'group' => 'www-data',

I appreciate you taking the time on this. Here is what my config.php has:

‘default_permissions’ =>
array (
‘dir_mode’ => 1517,
‘file_mode’ => 420,
‘user’ => ‘’,
‘group’ => ‘’,

Not really sure what to put in the user/group as this is a Windows machine. Would this be the iusr as this is running on IIS?




It should be “IUSR_[computerName]” for both user and group where computerName is your computer’s name.

The full guide for windows permissions is here:

Same problem after making those changes. The folder permissions were already set. Not sure if I mentioned this, but this only started after upgrading.

Next step?



If you are sure your permissions are correct then please clear your cache for your browser, ctrl+f5, and try again.

If it still fails then after trying to update a case through the Subpanel on an Account, Please check your sugarcrm.log and suitecrm.log files to see if there are any errors.
Also, check your console if there are any errors before, during or after the process. You can open console with ctrl+shift+k on Firefox or ctrl+shift+j on Google Chrome

I have the same problem. Permissions seem to be ok, I have the latest Suitecrm installed but when I try to add a case update though the save button in the case view form, it does not save and the javascript console shows the following:

VM5153 index.php?action=ajaxui:1 Uncaught ReferenceError: caseUpdates is not defined
onclick @ VM5153 index.php?action=ajaxui:1

If I edit the case and use the udate text field then I have no issue. But it would be much more convenient being able to add updates without having to access the edit view.

Most of my problems were solved when changed my hosting provider …