Can't remove old language packages

How to remove old language packages ?

Hey @InfoLibre (welcome!)

Are you able to give us more details.

  1. What version of SuiteCRM are you using?
  2. What version of PHP are you using?
  3. What are the steps you take and expected behaviour? The screenshot shows the php warnings but I’m unable to understand if you had clicked the ‘Disabled’ or ‘Uninstall’ buttons.

@samus-aran please note the picture show 2 problems: the PHP warnings and 3 entries for the same language .
On the triple entries it happens if you install a language pack without uninstalling that language old pack first.
Related here: https://github.com/salesagility/SuiteCRM/issues/2295#issuecomment-517823315
Its a real problem as people needs to uninstall a language pack in order to update it in full (in order to remove unused language files)!

@InfoLibre This do not help on the actual issue but can help on your Github issue in order to use the new translation in full.
After installing a language pack you need to make a Quick rebuild and also to rebuild the language javascripts (admin)
see: https://sites.google.com/site/translatingsuitecrm/faq/updating-languages

Made uninstall/install again, and then repair, rebuild…
Same problem

Before installaing the new package, I wanted to uninstall the 2 older, but impossible, no buttons.

Are you using XAMPP? It usually behaves terribly with SuiteCRM until you disable display_errors in your php.ini and restart your web server.

Any way, even if that’s not what your using, I think its worth trying to clear those errors from the screen, as they sometimes break other parts of the screen. So those errors that are visible could be the cause of the buttons that are invisible.

On the disabled buttons (for previous “updated” language packs) I don’t have those errors and that is a bug for some time (since 2016)!
Unless someone can repeat the language update process (not uninstalling old packs) and the old entry is cleared… its a bug!

You’re right, sorry, I just saw the GitHub issue minutes ago and now I understand. :frowning:

1 Like

As I was answering both horus and yourself in the other post I wanted to reference parts of it that is relevant to you. :slight_smile: As I suspect this is an instance specific issue rather than a core bug (but the jury is still out on that one) then I’ll continue answering here…