Cant install Suitecrm 8.2


I’m having problems installing SuiteCRM 8.2 from a fresh copy using Ubuntu 22.04 and PHP 8.1

The installation questionnaire page comes up, but the proceed button does nothing.

If I use the alternate url /legacy/install.php, that works but then my password does not work, unless I use /legacy/index.php.

Is this supposed to work?


After spending quite a bit of time on this, I’m finding multiple people with the similar issues and there has been no fix for this.

I’ve tried again with a fresh copy of Ubuntu 22.04 and PHP 8.0 to keep it mainstream as possible with the same results, using 8.2.3

Top right column of the setup page, there’s a field thats blank. It almost looks hidden because its blank and empty to install ‘demo data’. If you don’t select yes or no you can’t move on. Can you post a screenshot so I can confirm? I had the same issue when I tested out 8.2.x

100% correct!

Yes that was it.

Now working! Thanks heaps :slight_smile:

Can you show me the steps that you did to install Suitecrm 8.2 on Ubuntu 22.04. I’ve been having difficulty with it.

Well basically

  1. Install Ubuntu server
  2. Install PHP 7.4 by adding the ondrej repo (this is for compatibility reasons)
  3. Install the extra php modules required
  4. Install mysql-server
  5. Create a database and database user with permissions to said database
  6. Download the zip file and unzip to the /var/www/html directory
  7. Edit the 000-sites-available to target the root as /var/www/html/public and add the rewrite stuff
  8. Enable re-write ( a2enmod rewrite)
  9. Chown the files in /var/www/html to owner www-data:www-data (DO HIDDEN FILES TOO!)
  10. go to the site and configure the settings and be sure to select the option to either populate or not populate with demo data, this is hard to see and seems to be a bug, but as long as you choose an option, it works.

Thats a basic rundown. Let me know if you have trouble.

This is what I did before
sudo nano /etc/apache2/sites-available/suitecrm.conf.

<VirtualHost *:80>
ServerAdmin admin@localhost
ServerName localhost/suitecrm
DocumentRoot /var/www/html/suitecrm/public
<Directory /var/www/html/suitecrm/public>
AllowOverride All
Order Allow,Deny
Allow from All

ErrorLog ${APACHE_LOG_DIR}/suitecrm_error.log
CustomLog ${APACHE_LOG_DIR}/suitecrm_access.log combined

And added this in nano /etc/apache2/sites-available/000-default.conf

<Directory /var/www/html>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

It worked.

Because I tried your way and I had some problem. But will try again. Thanks