Can't Create or Modify Fields in Studio

Hello,

I’m having trouble editing or creating new fields in the studio. I get the following message whenever I click on an existing field for modification or click “ADD FIELD”:

" Warning: Creating default object from empty value in /var/www/suitecrm/modules/ModuleBuilder/views/view.modulefield.php on line 151
{“east”:{“title”:“Edit Field”,“crumb”:"",“content”:"
</div>\n\n "

Some help would be kindly appreciated.

1 Like

Hi Kagbasi,

Turn off display errors in your php ini, this can effect the ajax interface of suitecrm.

Hope this helps
Lewis

I was having the same issue on HostGator. When I forced my install directory to be processed by PHP v. 5.3 (instead of 5.4) it resolved the issue.

In HostGator (cPanel) this can be done using the “PHP Configuration” tool from within cPanel.

Interestingly, when I changed it to PHP 5.3, which I thought was the recommended PHP version for SuiteCRM 7.X, that made it so that when trying to access the dropdown editor it just said “null”.

So now I’m working to use the method recommended here, which was to edit the PHP.INI file to hide errors. I have to figure out how to just do it for the directory SutieCRM is installed because I need those errors for other everyday PHP development.

I’m surprised SuiteCRM doesn’t have a way to set the error reporting level desired. I’m going to search for that now. B)

OK, My final fix was to do what I originally said (use PHP 5.3 to process SuiteCRM php files), but then remove the blank language in the languages tab to fix the null response on dropdown editor. See this thread:

https://suitecrm.com/index.php?option=com_kunena&view=topic&catid=4&id=684&Itemid=1136

(not upgrade safe. TIP: add a comment that you can find using grep later to roll your patches over)

add this line of code directly above line 151 in suitecrm/modules/ModuleBuilder/views/view.modulefield.php and it will work for PHP 5.4

if (!is_object($module->mbvardefs)) {
$module->mbvardefs = new stdClass();
}
1 Like

Speaking of not upgrade safe… here is another solution that should fix the problem…

How to hide errors without editing php.ini:
https://suitecrm.com/index.php?option=com_kunena&view=topic&catid=12&id=2278&Itemid=1136

same error on Version 7.11.13
Sugar Version 6.5.25 (Build 344)
PHP Version 7.3.17
Apache/2.4.43 (Win64) OpenSSL/1.1.1f PHP/7.3.17
Accounts module, I had added fields in previous version.
Now I want to add a new field, and when I press Add Field I get the same error .

ddd{“east”:{“title”:“Edit Field”,“crumb”:"",“content”:"

</div>\n\n