Can't configure tabs


I can’t modify the tabs available in the header. The menu in Admin is here : index.php?module=Administration&action=ConfigureTabs

When I try to save, it tells no action available. I check the code, and it seems the action SaveTabs is missing in Administration. What could be the problem?

I’m on SuiteCRM 7.2.2.


This works for me. I tested it on both 7.3.1 and 7.2.2.
Could you please check that your Server/file permissions are correct and that your owner/group user settings are correct.
Afterwards, do a quick repair/rebuild.

If this does not help then please check if your sugarcrm.log/suitecrm.log files contain any error messages.

Thanks, John


Thanks for your help.

First, I chown 777 -R every files of SuiteCRM for the sake of testing.

Second, I did a Repair

Third, I flush the log clean before trying to save the tabs.

And it still doesn’t work. My sugarcrm.log and a print screen are attached.


I found out my problem. Turned out I created a custom controller for the Administration module, but didn’t extend the controller of Administration. I correct it, and now it works.

Thanks for your help!