Can't add accounts to target list

I am not positive this is a bug…When using the target list module and account module to add accounts to a target list…it will not add them. It will output array information instead like the following:

This is just a brief output of it. There are pages upon pages of this output.

I also can’t run a complete diagnostic. It stalls at 15% and shows Getting… Database info… Database dumps… Database schema. If I uncheck MySQL - General Information it will complete the diagnostic. I have attached the diagnostic minus the MySQL General Information. Would like to know why this won’t work if it is selected.

Thinking there is a restriction of 50 records at a time, decreased the selection to just 50 records and did not run into any problems.

I have noticed this thread as well:

No apparent solution was found.

Is there a way to increase the amount of selections to greater than 50 at a time? This could take a while to update the list of 14,000 records.

I have found that when processing any target lists, even from campaign results…if there is a large number of contacts… I run into that array message appearing and the action not being completed.

In campaign results, there is no way to check a certain amount of the contacts and add them to a new target list…you can only add all of them in that section to a target list.

There has to be a cause for this…very frustrating…


I ended up getting this issue ‘resolved’…

// Do not store anything in this file that is not part of the array or the hook version.  This file will
// be automatically rebuilt in the future.
 $hook_version = 1;
$hook_array = Array();
// position, file, function
$hook_array['after_ui_frame'] = Array();
$hook_array['before_save'] = Array();
//$hook_array['before_save'][] = Array(77, 'updateGeocodeInfo', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook', 'updateGeoco$
$hook_array['after_save'] = Array();
//$hook_array['after_save'][] = Array(77, 'updateRelatedMeetingsGeocodeInfo', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook'$
//$hook_array['after_save'][] = Array(78, 'updateRelatedProjectGeocodeInfo', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook',$
//$hook_array['after_save'][] = Array(79, 'updateRelatedOpportunitiesGeocodeInfo', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogic$
//$hook_array['after_save'][] = Array(80, 'updateRelatedCasesGeocodeInfo', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook', '$
$hook_array['after_relationship_add'] = Array();
//$hook_array['after_relationship_add'][] = Array(77, 'addRelationship', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook', 'ad$
$hook_array['after_relationship_delete'] = Array();
//$hook_array['after_relationship_delete'][] = Array(77, 'deleteRelationship', 'custom/modules/Accounts/AccountsJjwg_MapsLogicHook.php','AccountsJjwg_MapsLogicHook$


I disabled everything related to MapsLogicHook and it worked fine.

I am concerned about disabling items because they are obviously there for a reason…