📣 We're Hiring!

Cannot load DB manager. 2 apache servers instances. MariaDB. Debian

Hi,

So i have encountered a problem. I am running from home server ( raspberry Pi) with nexcloud running on apache2 server.

Second server has been set up as apache2-suiteCRM as a second instance running on port 8443

I have placed all installation files and permissions adjusted in the correct www-data owned folder. When i run install i get to the 3rd page. All checks were OK. When i hit install i run into a problem: Can not load DB manager.

i googled, i tried, i lost hope :slight_smile: . I have set up mariaDB with a distinct user and all privileges needed to use the suitecrm database i have set up in mariaDB. (php7.3) I created a user in mariadb named stephane with a password. I can access mariadb through:

root@nextcloudpi:/var/www# mariadb -u stephane -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 3040
Server version: 10.3.27-MariaDB-0+deb10u1 Debian 10

Copyright © 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> show databases
-> ;
±-------------------+
| Database |
±-------------------+
| information_schema |
| suitecrm |
±-------------------+
2 rows in set (0.001 sec)

MariaDB [(none)]> show grants
-> ;
±----------------------------------------------------------------------------------------------------------------+
| Grants for stephane@localhost |
±----------------------------------------------------------------------------------------------------------------+
| GRANT USAGE ON . TO stephane@localhost IDENTIFIED BY PASSWORD 'B5C22307E591759F705980B50A121E85D5CE76B9’ |
| GRANT ALL PRIVILEGES ON suitecrm.
TO stephane@localhost |
±----------------------------------------------------------------------------------------------------------------+
2 rows in set (0.000 sec)

I am not seeing any problem here either.

I am wondering though, if the second apache2 server instance running under the name apache2@suiteCRM.service , if it can actually reach the mariaDB database. I assume that if you just install apache2 and than mariadb that they are able to find eachother. i think that somewhere with a second instance this is going wrong somewhere along the road. But not a clue how and where.

Thanks for any input. It would be a great help.

PHP needs DB modules to be installed in OS, and activated in php.ini

Your PHP error log is telling you about this problem, have you been checking it?