Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Cannot Install SuiteCRM8 on win10

wamp php 8.0.13 Mysql 5.7.36

Sat Nov 27 18:45:13 2021 [10156][-none-][FATAL] Error creating table: leads: Query Failed: CREATE TABLE leads (id char(36) NOT NULL ,date_entered datetime NULL ,date_modified datetime NULL ,modified_user_id char(36) NULL ,created_by char(36) NULL ,description text NULL ,deleted bool DEFAULT ‘0’ NULL ,assigned_user_id char(36) NULL ,salutation varchar(255) NULL ,first_name varchar(100) NULL ,last_name varchar(100) NULL ,title varchar(100) NULL ,photo varchar(255) NULL ,department varchar(100) NULL ,do_not_call bool DEFAULT ‘0’ NULL ,phone_home varchar(100) NULL ,phone_mobile varchar(100) NULL ,phone_work varchar(100) NULL ,phone_other varchar(100) NULL ,phone_fax varchar(100) NULL ,lawful_basis text(100) NULL ,date_reviewed date NULL ,lawful_basis_source varchar(100) NULL ,primary_address_street varchar(150) NULL ,primary_address_city varchar(100) NULL ,primary_address_state varchar(100) NULL ,primary_address_postalcode varchar(20) NULL ,primary_address_country varchar(255) NULL ,alt_address_street varchar(150) NULL ,alt_address_city varchar(100) NULL ,alt_address_state varchar(100) NULL ,alt_address_postalcode varchar(20) NULL ,alt_address_country varchar(255) NULL ,assistant varchar(75) NULL ,assistant_phone varchar(100) NULL ,converted bool DEFAULT ‘0’ NULL ,refered_by varchar(100) NULL ,lead_source varchar(100) NULL ,lead_source_description text NULL ,status varchar(100) NULL ,status_description text NULL ,reports_to_id char(36) NULL ,account_name varchar(255) NULL ,account_description text NULL ,contact_id char(36) NULL ,account_id char(36) NULL ,opportunity_id char(36) NULL ,opportunity_name varchar(255) NULL ,opportunity_amount varchar(50) NULL ,campaign_id char(36) NULL ,birthdate date NULL ,portal_name varchar(255) NULL ,portal_app varchar(255) NULL ,website varchar(255) NULL , PRIMARY KEY (id), KEY idx_lead_acct_name_first (account_name, deleted), KEY idx_lead_last_first (last_name, first_name, deleted), KEY idx_lead_del_stat (last_name, status, deleted, first_name), KEY idx_lead_opp_del (opportunity_id, deleted), KEY idx_leads_acct_del (account_id, deleted), KEY idx_del_user (deleted, assigned_user_id), KEY idx_lead_assigned (assigned_user_id), KEY idx_lead_contact (contact_id), KEY idx_reports_to (reports_to_id), KEY idx_lead_phone_work (phone_work), KEY idx_leads_id_del (id, deleted)) CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci: MySQL error 1071: key is too long. Maximum length: 1000

thanks for your help

Solution :

Advanced Database Configuration

Collation : select utf8_general_ci

2 Likes

Hi @PINAIT

Welcome to the community! :wave: And thanks for trying out SuiteCRM 8.

Sorry for the delay in replying.

Glad you were able to solve it!

If you have any feedback about SuiteCRM 8 please consider having a look at the following topic:

The login and password only works at the following address: http://localhost/suitecrm/public/#/Login
“login credentials incorrect, please try again”

The screen is incomplete when I am at the following address with the administrator login and password:
http://localhost/suitecrm/public/legacy

Hi @PINAIT ,

Yes, that is correct. The ‘http://localhost/suitecrm/public/legacy’ should not be accessed directly, it is there to be used in the classic view.

Hi @PINAIT ,

Sorry I misread your message.

On the route http://localhost/suitecrm/public/#/Login

Could try refreshing and then trying not login again, please?

And please close any tabs pointing to /legacy

I tried the route http://localhost/suitecrm/public/#/Login:
I still have the message “login credentials incorrect, please try again”

Hi @PINAIT,

Thank your for your feedback.

Could you check the /public/legacy/suitecrm.log please? to see if it has any errors?

Another log to check is /logs/prod/prod.log

Here is the content of the log files:

Acapela icon|59pxx16px

suitecrm.log :
Sun Nov 28 16:12:16 2021 [4000][-none-][FATAL] Could not connect to DB server PORT01\SQLEXPRESS,1433 as sa. port : php_network_getaddresses: getaddrinfo failed: Hôte inconnu.
Sun Nov 28 16:12:33 2021 [4000][-none-][FATAL] Could not connect to DB server PORT01\SQLEXPRESS as sa. port 1433: php_network_getaddresses: getaddrinfo failed: Hôte inconnu.
Sun Nov 28 16:12:47 2021 [4000][-none-][FATAL] Could not connect to DB server SQLEXPRESS as sa. port 1433: php_network_getaddresses: getaddrinfo failed: Hôte inconnu.
Sun Nov 28 16:13:52 2021 [4000][-none-][FATAL] Could not connect to DB server .SQLEXPRESS as sa. port 1433: php_network_getaddresses: getaddrinfo failed: Hôte inconnu.
Sun Nov 28 16:16:48 2021 [4000][-none-][FATAL] Could not connect to DB server .SQLEXPRESS as sa. port 1433: php_network_getaddresses: getaddrinfo failed: Hôte inconnu.
Sun Nov 28 16:17:28 2021 [4000][1][FATAL] User update error: Temp User is not retrieved at ID 1, boolean given
Sun Nov 28 16:17:28 2021 [4000][1][FATAL] Email address save error
Sun Nov 28 16:17:31 2021 [4000][1][SECURITY] Setting logger_file_name to ‘’.
Sun Nov 28 16:17:31 2021 [4000][1][SECURITY] Invalid ext logger_file_ext : ‘’.
Sun Nov 28 16:17:31 2021 [4000][1][SECURITY] Setting logger_file_ext to ‘’.
Sun Nov 28 16:17:31 2021 [4000][1][SECURITY] Log file extension can’t be blank.
Sun Nov 28 16:17:31 2021 [4000][1][SECURITY] Log file extension can’t be blank.
Sun Nov 28 16:17:32 2021 [4000][1][SECURITY] Setting logger_file_name to ‘’.
Sun Nov 28 16:17:32 2021 [4000][1][SECURITY] Invalid ext logger_file_ext : ‘’.
Sun Nov 28 16:17:32 2021 [4000][1][SECURITY] Setting logger_file_ext to ‘’.
Sun Nov 28 16:17:32 2021 [4000][1][SECURITY] Log file extension can’t be blank.
Sun Nov 28 16:17:32 2021 [4000][1][SECURITY] Log file extension can’t be blank.
Sun Nov 28 16:17:59 2021 [4000][1][FATAL] log call at: modules/EmailMan/tpls/config.tpl:463 - styleChecked is not set
Sun Nov 28 16:19:17 2021 [4000][1][FATAL] log call at: modules/EmailMan/tpls/config.tpl:463 - styleChecked is not set
Sun Nov 28 18:19:20 2021 [4000][-none-][FATAL] SECURITY: User authentication for admin failed
Sun Nov 28 18:19:20 2021 [4000][-none-][FATAL] FAILED LOGIN:attempts[1], ip[127.0.0.1], username[admin]
Sun Nov 28 18:19:35 2021 [4000][1][FATAL] log call at: modules/EmailMan/tpls/config.tpl:463 - styleChecked is not set

prod.log :
[
prod.zip (2.3 KB)

Thank you for your answers