Cannot authenticate SMTP for certain email addresses

SuiteCRM version: 7.14.3
PHP version: 8.2

Good afternoon,

We are trying to add an outbound email account from Administration > Outbound Email.
After correctly configuring the smtp server, testing the configuration yields a “smtp could not authenticate” error.
We know for a fact the configuration is correct as it works on other clients (we tested Thunderbird).
We know for a fact the configuration test is working, since it works with other configurations (on the same ports as well).
We do not know of any steps similar to lowering google’s security that might have to be taken with this provider, as an internet search didn’t yield any results on the matter.
We suspect the issue could be that the email ends in, and it could be that it isn’t sitting well with the email format Suite is expecting but we aren’t sure how to corroborate these suspicions.

Any help is gladly appreciated.

I would look for messages in the logs, not just FATALs, but other warnings and maybe even info.

If the issue is with the email validation, I believe you will find messages when the email is discarded.

See this

After checking the logs it seems these lines are related, but I wouldn’t be able to tell what the issue could be from them:

Tue Jun 25 12:54:02 2024 [763917][1][WARN] Request ssl value not found.
Tue Jun 25 12:54:02 2024 [763917][1][WARN] Requested folder is not defined
Tue Jun 25 12:54:02 2024 [763917][1][FATAL] ImapHandler trying to use a non valid resource stream.
Tue Jun 25 12:54:02 2024 [763917][1][FATAL] ImapHandler trying to use a non valid resource stream.

As for the EmailFrom validator, I don’t think it’s interfering since when we didn’t properly configure the emailfrom we would get an error message about it, but this error message wouldn’t show up even with the mail in the Email From field.

The messages seem to be coming from here

It seems it is not trying to use SSL, but needs to? Some time ago there was a bug where the email configuration screen would not save the option for the dropdown TLS / SSL / None. I would even check that in the database, inbound_email table, make sure the settings are correct there.

In that case, it might be unrelated to the outbound email configuration problems we’re facing, since there is no inbound email record for that email. On the other hand, the existing inbound emails might have broken…

Or maybe I am just confusing inbound_email with outbound_email :smile:

Still, it’s good advice to check if the email account settings are well saved in the DB

The test is failing before a record is created, and after as well. We’ve checked the database columns and nothing seems out of place… if it was the testing routine itself, we could try sending an email to see if that works but we just found that trying to access the emails module or the email queue from the administration panel yields a 504 gateway timeout error… there might be more things going on under the hood than initially thought

After configuring the inbound email account (which gave me an authentication error in testing, but by manually writing INBOX in the check folder field it just… worked) and assigning the (not working according to email test) outbound email account, from the Email module I was able to send an email… so it seems to be a problem with the configuration testing

Master email class


If you follow the steps in my email video kindly linked by @rsp and it’s still not working, report back. I’ll follow this post. I’ve worked through all kinds of email problems, I’ll help if I can.

Pay special attention to the inbound setup. I’ve never setup just an outbound without and inbound, so you could be in uncharted waters, I can’t confirm personally if outbound will work all by itself without and inbound associated.

I have setup the inbound email account as well as the outbound, and I can see new mail as well as send mail with the outbound email account. The issue with the testing persists, but the email itself is working. Now I have to figure out why the scheduler seems to have broken, but that’s a separate thread probably…

The scheduler will break if you main system email account cannot connect. I’d start there.

1 Like