Cannot add Dashlets

No users can add dashlets, even system administrator. When I try to add a dashlet I see three lines in the error log. You can see that it is trying to include a blank file name.

[03-Jul-2014 20:17:25 UTC] PHP Warning:  array_unshift() expects parameter 1 to be array, null given in custom/include/MySugar/MySugar.php on line 116
[03-Jul-2014 20:17:26 UTC] PHP Warning:  require_once() failed to open stream: No such file or directory in custom/include/MySugar/MySugar.php on line 150
[03-Jul-2014 20:17:26 UTC] PHP Fatal error:  require_once() Failed opening required '' in custom/include/MySugar/MySugar.php on line 150

I have checked permissions on the folders.
I have did repair and rebuild.
I tried resetting the home page in user preferences.
I checked the console for errors in the browser and I do not see any when I inspect the elements and try to add a dashlet.

What can I do next?

Hi there,

What is your Server/MySQL/PHP setup? What permission did you set for the SuiteCRM directory?

What version of SuiteCRM are you running? Is this a clean install or an upgrade?



1 Like

Hello, thank you for your help.

The server is CentOS 5.9 and it is not a shared server. MySQL is 5.1 and PHP is 5.3.15. The SuiteCRM version is 7.1.1 and it was a clean install with the full version about 6 weeks ago. This is the version from your site shortly before you came out with the 3 different configurations for sales, service, and max.

The SuiteCRM folder is 755.

The system seems to be working as expected in every other respect.

Though there are no errors in the console, I will mention that something on the page (javascript I assume) is tracking the dashlets I am trying to add. That is to say, If I keep clicking to add a dashlet, eventually the page will spawn an error dialog that says I have reached the maximum number of dashlets, but when I refresh the page there are no new dashlets. I get those three error lines for each click where I try to add a dashlet.

Hi there,

We would recommend the following permissions on your SuiteCRM instance(although these may vary slightly:

sudo chown -R [owner]:[group] .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php

Also, can you list the errors you receive in your console when trying to add a dashlet?



1 Like


Those are the permissions in effect, except that for the chown command my server has a different group and owner. (It breaks the site when I set apache:apache.) I put in the chmod commands you have shown me just to be sure but still no luck.

I checked the console and there are no errors. After 11 clicks I get a message “You have reached the maximum number of Sugar Dashlets…” but still no console errors. I do get the 3 error_log lines as shown before.


I had the same problem. It started working again when I did this:

  • Create a new dashboard
  • On the new dashboard, add a dashlet - that worked
  • Go back to the default dashboard - that worked.
  • Delete the new dashboard
  • Add/remove dashlets to the default dashboard as required.

However, if you log out and in as a different user, it is broken. If you create a new user, it is broken until they do the steps listed above. When a user logs out, and logs in again, it is broken until they do the steps listed above.

Any thoughts?



I run version 7.2.1 and also cannot add dashlet to the dashboard. Well, at first, I deleted 2 and added one but I cannot add any more.
Any idea?


Hi, I am having the save issue with with version 7.1.4. The permissions and file ownership are correct. Nothing is being logged in sugar log or php log. I have used Chrome, IE and Firefox and it doesn’t work in any of these browsers. I am looking at activity in Firebug and I see no errors. Interestingly, it is not working on my production instance but works correctly on my development instance. I notice on the Firebug console that the HTML is generated correctly but saveLayout is not being called. Anyone have any ideas as to the problem?


Hi Dianna,
I found a way around in that I have added a tab and then added the dashlets I wanted on that tab. But still cannot add dashlets to the default tab.

Adding a new tab and adding dashlets to that doesn’t work either.

After several months of trying every suggested solution, I finally discovered my problem by backing out changes until the problem fixed itself and then adding them back in until I was again unable to add dashlets. I had created a custom module and added Security Groups to it using the information provided in the Security Suite Administration Guide Version 2.0 on how to enable Security Suite for a custom module. This requires that you edit a file and I cut and pasted the information from the admin guide. What I did not realize is that the file contained an extra line after the closing ?> which caused this problem. Very hard to find because it really had nothing to do with adding a dashlet but I thought that I would let others know that this problem could cause this behavior.