Cannot add dashboard tab

Hi all.

I’ve just started using SuiteCRM for our small painting business :cheer:

I’m having trouble adding a tab to the dashboard. Clicking on Add Tab brings up a dialogue box asking for the tab name and number of columns which I fill in and then click Save. The result is that page refreshes but no tab appears.

I am running Suite CRM 7.1.4 on a hosted server running php 5.3.29. My browser id Firefox 34.0.5 on OpenSUSE 12.3 operating system.

Any assistance would be appreciated.

I can provide a copy of the log file if required.

Hi there,

It could be a permissions issue. Did you set permissions on the files once installed?



No. I installed suiteCRM from my host using their Softaculous script provided in the cpanel.

I have my installation in a directory called suitecrm. Under that directory all the directories are 0755 and the files are 0644. Should everything under suitecrm the directory be 0755 then - all files and directories including the sub-directories and files?

The permissions should be as follows

755 all files then

775 cache custom modules themes data upload config_override.php and all files inside these

This might be why you are seeing problems.

1 Like

Thanks Ian. I’ve just gone through and made the changes to all the permissions and still am unable to add a new tab to the dashboard.
What else could be preventing this apart from permissions? I can attach a log if that would help but would need guidance on how to do that.

Even as the Suitecrm administrator I cannot add an additional tab to the dashboard.

have a look at the console in the browser. if you are using firefox you can press Shift+Ctrl+K, then if you try to add a tab and see if any notices appear.

the other place to have a look is in the base folder of SuiteCRM looking for a file call sugarcrm.log which after you have tried to add a tab there maybe a notice or two in there.

The first is far more likey to have a notice.

Great. I got something in the console. 2 items show up. The first item is a warning and I assume that it isn’t the problem. I don’t understand the reason for the second error. I checked the permissions for the colorselector.php file and it’s 775 which is correct I assume?

Use of getAttributeNode() is deprecated.        Use getAttribute() instead. sugar_grp1_yui.js:61
GET https://my-domain/suitecrm/themes/Suite7/css/colourSelector.php        [HTTP/1.1 500 Internal Server Error 136ms]

It’s difficult to setup a well running SuiteCRM installation on any host. You are not in control of what happening on that server.
Installation scripts provided by the hosting company I never believe in them because they are little or not tested and most of the time behind in updates etc.,

My two cents of how i handle this:

Setup up a virtual Ubuntu machine on your desktop of laptop. I use the free Oracle Virtual Box for this with a standard Ubuntu 14 Server edition.
You can also download Bitnami with SuiteCRM installed on it, personally i don’t like them because you have to install a lot of tools like phpMyAdmin and Webmin to make it workable.
Do the installation on this virtual machine configure everything properly and than move the whole installation to your hosting account.

When doing updates or other major work on your CRM installation, download the files from you host and perform the update on your virtual machine.

This method of working is secure, you always have a backup and saves you hours of trouble shooting at a hosting account with limited permissions. If you have any issues you know that the problem is the hosting provider and it’s easier to give them a clear picture of your problem. If this is still not working time to set up and Amazon AWS account and run an EC2 instance. (any other cloud provider will also work). Still problems hire a PRO.

OK, I’ll try a local installation and see how that goes.