Campaigns not allowing users to select outbound email account, admin works fine

Hi, I hope someone will be able to help me out. I’m having this really weird issue. I am using the latest SuiteCRM version. The users are not able to run campaigns from their accounts.

The email outbound account field is empty on the Campaigns -> Marketing tab .

The permissions are fine for these users and users are able to view and send emails from the Email module.

I’m not sure what’s missing. Debug doesn’t show any errors. The admin can view and select outbound email account without any issues on the campaigns.

I have tried to search for this error online, but not getting any proper answers or resolutions. I would appreciate it if someone can guide me in getting rid of this issue. I don’t want to assign users with Admin role just to resolve this issue. Does anyone else has experienced the same issue?

Anyone? Am I the only one who’s facing this issue. Can someone help? This CRM will not be of any use if you can’t run Campaigns via users’ accounts.

Hey there,

hmmm, I wouldn’t expect there to be any sort of admin-only restriction here

I’d given it a try on SuiteCRM 7.11.18, and I’m currently able to see the Outgoing Email Accounts, when logged in as a non-admin:

So i’ve got some quick questions:

  • What version of SuiteCRM are you on?
  • What version of PHP are you using?
  • Are the afflicted users in any Security Groups / Roles for either the Campaigns/Emails modules?

It might be a stretch, but it could be worth resetting the file/folder permissions, to ensure access is available where expected.
We recommend:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chown -R www-data:www-data .
(replacing www-data with whatever your web server user is)

As well as running a Quick Repair and Rebuild

1 Like

Thanks for getting back. I have the same version 7.11.18. Let me try it and then I will let you know if that resolves the issue.

Ok, I have tried what you asked me, but it didn’t resolve the issue. It’s still show empty field. my server php version is 7.2.34 and yes, the users are in the Security Group.

I’ve also checked the my log again, I’m getting following errors.
[384][1][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Tue Feb 23 19:02:46 2021 [3341][1][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Tue Feb 23 19:02:49 2021 [3341][1][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Tue Feb 23 19:02:49 2021 [3341][1][FATAL] SugarBean::populateDefaultValues $field_defs should be an array
Tue Feb 23 19:03:30 2021 [384][7cb63a54-93dd-4e64-84f7-5fd957f86501][FATAL] SugarBean::populateDefaultValues $field_defs should be an array

Is this related ?


I don’t believe those errors are related, I’ve seen them pop up for various actions/reasons

It sounds like you’re on a compatible CRM/PHP version too, so thanks for that info!

How restrictive are the Campaigns/Email permissions, for those users in the Security Group that effects those modules?

If possible, could you try creating a user NOT in a Security Group, and trying this with that user?
Does it seem to work then?

Are you aware if either the Campaigns module or the Email functionality have had any customizations made to them?
(Either in Studio or via Code)

If not, i’m not really sure where else to check :confused:

Yes, if the users are not in any security group then it works. So I guess it’s a permission issue. But I want these users to be in the security group so they don’t have access to everything.

I can try making a new security group and see if that helps.

Sounds like a good plan, let us know how it goes!

What are the Role permissions for that Group?
It might be something set there that’s causing this, and itd be good to know to try to replicate

Finally, I was able to resolve this issue. Thanks for leading me in the right direction.

I assigned the user to another security role and that resolves the issue immediately. I matched the permissions for both security roles and the only difference I found was that the Outbound Email Accounts was enabled (with owner permissions) on the security role which was having the issue. So I disabled it and now I’m able to set campaigns without any issues :slight_smile: . What does this setting mean?

Thanks again for all your help. Hope this helps someone else if they ever ran into this issue.

1 Like


Great, Glad to hear!

So, for clarity;

The “Outbound Email Accounts” module would be the one you would find in Admin->Outbound Email

And “Owner” permission would mean that the user is the assigned user of the record.

When Outbound Email Accounts are created, (either manually or via the User Profile->Email Settings popup), they seem to be created with either:

  • No assigned User (NULL)
  • Assigned to the default admin user (id:1)

So, as ordinary CRM users would never be assigned to an Outbound Mail Account, they would never see them as they are not the "Owner"

Hopefully that makes sense, but let me know if it needs clarification!