Campaign not working from Admin & No out bound email account in Dropdown from User Campaign Account

Hello there,

I am upgraded CRM from 7.9 to 7.10.2.

I am facing problem in running campaign from Admin & User Account. In Admin though everything seems perfect, Its not pushing the mail. Mails Keeps lying in Queue like forever. When I tried to push mail manually from Admin account It gives back blank screen with no result, no error in log. I am sharing few Screen here.

From Personal account, When I go in Launch Wizard of Campaign, It shows no Outbound Email Account in Dropdown Menu, though I have set Email account for User & Its sending test mail successfully and Even I can sent email from Personal account using Email Module.

It shows User Outbound & System Account both in Admin Panel.

Same Window from User Account where there no Dropdown menu for Outbound Email Account.

I have few more links but I am not able to attach those file here. When I click on Add File Nothing happens.

View Log

Your log shows an error opening email folders, so that is Inbound email (IMAP). Can you try fixing the inbound email, to keep that error from appearing, and see if that solves the other problem?

Yes It shows certainly that but I fail to understand that My User Account Inbound Mail is Perfectly fine. I can see all the messages & I can even compose mail from there. In bounce handling mail also, I have tested it and its even working properly.

What even surprise me is when I go to Admin Module & Try to push Email in Queue Manually, It shows me Blank Screen & Nothing happens after wards. In Address bar link, Its show & It wont generate a Log either.

Dear PGR,

I have found one solution at the moment. In Run Nightly Mass Email Campaigns edit mode, When I have changed to 1 minute from 2 hours. But there was a typo error. In minute field it was 1 & In Hours field it was *18 by mistake. As Text Input box was showing only 1 digit & it accepted that value. I was not knowing what was happening and I was not even getting error for the same. I went through every little thing I changed after upgrade and found that out.

My other issue still there. In users account, when I try to run campaign, I cannot see any drop down frrm Outgoing Email Account. In Admin account, It shows both System & User Account.


Though I am not technical person, with the help my website developer I have used every trick available on net for my campaign to run

Current Status

  1. Run Nightly Mass Email Campaign running successfully every minute.
  2. Bounce Handling Mail, Out-bound Email Account working file. No error in that even test mail going fine.
  3. When I launch Campaign, In Campaign Summery all 6 requirement are checked marked in Green. No issue in that.
  4. When I click “Send email at Schedule Time”. I even get msg. saying Email Schedule. I can see them in Queue with Schedule Time.
  5. My website developer has set cron job, and according to him. Its running perfectly. He has set them as shown in various forum on this site.


  1. Zero attempt to send email campaign.
  2. Mails keeps lying in queue.
  3. When I go to Email queue from Admin and Manually try to send. Nothing happens. No error on screen. No error on Log.

View Log error:
Every minute I get these errors.

Job 61bad479-f692-99a9-37fd-5ab3480b5daf (Run Nightly Mass Email Campaigns) failed in CRON run


  1. How shall I track down exact error?

Issue started when I upgraded from 7.9.8 to 7.10.2

Please help.

You can increase your log level to DEBUG, on Admin / System settings, and then get a full log of what that failed job is doing.

Try to make it at a time when no users are using SuiteCRM, to avoid mixing in other things.

Also, please make sure you set up your cron jobs in the correct crontab, for your web server user. It’s a common mistake to set it up for a different user. See Admin / Scheduler screen for instructions at the bottom.

Hello there,

I have tried everything to find out solution, but I am not getting drop-down while launching a campaign in User Account.

I have set all permission right. I have even check marked the “Allow users to use this account for outgoing email” from admin panel.

Thank you.

I made very specific suggestions on my last post, but you don’t comment on these? How did they go?

I would recommend that you focus on solving the bug with the Scheduler job, since that is much simpler code, and it will probably lead you into the solution for email account settings.

A couple more things I remembered:

  1. Do you have any files in custom/modules/Emails ?

  2. Have you checked the email accounts tables in the database? Sometimes that helps find things that don’t look right in your configurations. See outbound_email table, and inbound_email

Yes. I have changed a log to Debug mode but as I have explained you I have little knowledge of technicality. But our site developer have found issue in php coding after going through several trial and error. So Campaign is running now successfully from Admin panel.

There is still issue with Cache he said and that’s why sometime from normal browser when I launch campaign it won’t save Date & Time. I have to run campaign from Browser in incongnito mode. It runs nicely from there.

I will share you suggestion with him about email account Table. Will share more info on progress.

We have installed a fresh copy in another server but having same problem there. Admin can run campaign from System & User account but User cannot run campaign.

Yes I believe there is a bug somewhere. Can your developer explain what he changed to make it work? Thanks