Campaign module sub panel navigation is not working


Campaign module sub panel navigation is not working if we click on last button.
‘suitecrm_version’ => ‘7.11.10’,


Please help.


Do you have any javascript error in your browser console?


Uncaught SyntaxError: Unexpected token ‘<’
Uncaught SyntaxError: Unexpected token ‘<’

These 2 i have .


It seems you have ajax failed somewhere may be a warning, Please check your suitecrm.log and apache log.


I checked but don’t see anything related to this.

Can you please help how we can solve this.


Have you tried replicating this is in the live demo to see if the problem is only in your system, or a bug for everyone?

Only debuging can help as this is not the known issue.

  1. Check in your browser console, do you have any response in the network tab.
  2. Check the last log of the apache error log if it failed due to any php warning or error.


i tried but it is not helping.

can you tell me where i can get sub panel pagination code exactly.


Can you give me credentials ??


I tested the same issue on suitecrm demo ( )site as suggested and pagination problem exists here also in demo site. I believe it is a core bug.
i am able to solve this issue by removing int from offset in line no 888 from ListView file.
Path - include/ListView/ListView.php

kindly look into it and let me know.


This seems related to Issue #7608 and fix #7612 by @Dillon-Brown.

But in my 7.10.25 test system I have the new code and it runs fine, I can’t reproduce the bug… :thinking:


I have tested the solution at but the bug still exists.

I resolved this issue by removing int from the offset in line no 888 from ListView file.
Path - include/ListView/ListView.php

So can I push my changes to live?

How do you recommend me to resolve this issue at my end?
I have 7.11.10.

What exactly are the steps to reproduce the bug?

What I tried was creating a Campaign, and adding a bunch of targets, so that the Targets subpanel has more than one page, and then click that navigation.

Is this it?

With the original code (with (int) still in the code) do you see any messages in your logs?


Yes, correct you have to go to Campaign module, I have already added 11 records in the subpanel.

Please click on below link and test in subpanel -

the same issue exists in the account module and many other modules also. I have created one record in the account module also under the name - Jyoti test. You can check the same issue in the contact subpanel of the account module.

Note : pagination works if I remove int from the offset.

Works fine for me on Firefox, latest.

Which browser are you using?

Chrome Version 81.0.4044.122 (Official Build) (64-bit)

Firefox 75.0 (64-bit)

Not working in both.

Also works for me on the live demo, in the link you gave, you that same Chrome version. Maybe you have some add-on?

@pgr Does clicking on marked button (see pic - red box) redirects you to last page ?

Yes, you are right, of course.

Can you please test this fix instead?

Only removing the (int) isn’t enough for other cases (see older issues I link in my PR).

Thanks for your help reporting this.

1 Like


Thanks a lot. It worked. :smile:

1 Like