Campaign Emails are not sending

I’m trying to make Email Campaigns work on SuiteCRM but it is not sending emails. Emails are just stuck in the Message Queue. And I don’t have an option to send them manually. Version 7.10.6.

I have a template created.
I have a target list of 3 contacts total.
I create a new campaign using a wizard and choose necessary options.
All goes through.

When I schedule to send emails in 5 minutes, the emails appear in the queue but never get sent out.
My scheduler currently runs Nightly Mass Emails every minute for testing purposes. Scheduler log shows that it runs every minute.
Scheduler works properly because all other work flow email templates are being sent and working.

Why are my emails not being sent?

Also how do you push them out manually? I don’t see any button to send them manually.

Anyone??

Are you 100% sure your cron job is running on your server to process the queue? That would be my first place to look.

There should be a big red button at the bottom of your email queue that says “send queued campaign emails” if there’s not something is wrong.

The next thing I would check is that your outbound email is set up correctly. Did you send yourself a test email from the campaign?

My scheduled reminders have always worked because the scheduler is running workflow notifications every minute.

The scheduler also runs the Nightly Mass Emails every minute. You can see them being run every minute in the log of the scheduler.
Why would it still not send campaign emails out?

Also it says Messages Sent/Attempted: 0
Looks like it’s not even attempting to send them?

Here is a screenshot https://ibb.co/vZNxgmr
I’m not seeing a manual button anywhere.

Any idea?

Check:
Admin->(Email section) Email Queue

to see if the system has already attempted to send the messages. In such case it is waiting for 24 hours before attempting again.
Please post a screenshot (only a few unsent emails is sufficient)

Please also go to:
Admin-> (System section) Scheduler -> Run Nightly Process Bounced Campaign Emails

then take a screenshot of the whole page and post it here

Oh, that’s where you check the email queue.

I have a bunch on them stacked up in the queue. I select them and press send queued email campaigns and nothing is happening.
My email is configured correctly and the workflow notifications are sending out normally.

I try to help, but please follow instructions or else I will have to repeat them for ever!

1 Like

After you press the big red button, if you have lots of emails to send, it will not be noticeable they are sending. Refresh the page a few times and you should see the number go down. That will tell you it’s sending.

If it’s not most likely your outbound email account is not working. Send a test email from the campaign to yourself (add yourself to the test list) and see if you get it. If not, your outbound email for campaigns is not set up properly.

My email campaigns seem to be working now.

It seems like I can’t send emails manually more than 1 time?

What about a test email? When I click send test, it won’t send more than one time either.

This software is far too complicated and doesnt do the simple things it advertises. I have wasted about 20 hours just trying to get a simple campaign built, and the steps it requires ARE RIDICULOUS. CUMBERSOME AND UNINTUITIVE. WHY CANT YOU SELECT TARGET LISTS RIGHT OUT OF ANY EMAIL?

If it helps here’s a YouTube video I put together. Once you understand campaigns and how they work, it’s really not that difficult.

https://youtu.be/_YB90P2VS0U

did it all multiple times checked everythng, test emails send fine, using email module sends fine. Will nto send campaigns period. Checked every configuration, watched your video thanks. Pretty sure its buggy. Sent about 20 campaign tests. think I will uninstall and find something else, not loading this on my clients. thanks