Calender not loading


I recently installed SuiteCRM and I wonder why I cannot get the calendar working…
I get a white big screen…

Why its not working?

Cheers :cheer:

Hi Liz,

Have you checked your sugarcrm.log file? Have you performed a Quick Repair & Rebuild?



Hi Will! Where can I find that file? I recently installed it again and the same problem.I am using Siteground as hosting…


Seems like it could be a permissions issue or a JavaScript issue, what browser are you using?

To view the the log go to Admin->System Settings and scroll down to the bottom panel and click ‘view log’

@proliz: If you are still having this issue, let me point out that the click-to-add feature in “Calendar” will behave like that if you have restricted access to the “Meetings” or “Calls” module for the logged in user.

I have the same issue. My install was Dec20,2013, straight from the mothership. 6.5.16 I think.
How can i tell if my permissions are good or BAD?

Hi Mike,

If you are hosted you would need to check with your hosting provider to find out the exact details of what permissions are set on your SuiteCRM instance.



Same problem. Have tried all suggestions. Been through permissions, repair, checked on IE, Firefox and Chrome. Same thing.

Any suggestions? Thank you.

My calendar grid will not display UNTIL I right click and inspect the grid with inspector/firebug, etc.
Then, meetings and tasks will only show up in the Month view, no other views. I can only add meetings and tasks from the Month View.

My browser (Firefox 28.0) produces this error: SUGAR.language.languages.app_list_strings is undefined Line 128

This error seems to be related to the following lines in modules/Calendar/tpls/repeat.tpl

<script type="text/javascript">	
	function toggle_repeat_type(){
		if(typeof validate != "undefined" && typeof validate['CalendarRepeatForm'] != "undefined")
			validate['CalendarRepeatForm'] = undefined;
		if(document.forms['CalendarRepeatForm'].repeat_type.value == ""){
			document.getElementById("repeat_interval_row").style.display = "none";
			document.getElementById("repeat_end_row").style.display = "none";
			document.getElementById("repeat_interval_row").style.display = "";
			document.getElementById("repeat_end_row").style.display = "";
		var repeat_dow_row = document.getElementById("repeat_dow_row");
		if(document.forms['CalendarRepeatForm'].repeat_type.value == "Weekly"){ = "";
		}else{ = "none";

Relevant part here …

		var intervalTextElm = document.getElementById('repeat-interval-text');		
		if (intervalTextElm && typeof SUGAR.language.languages.app_list_strings['repeat_intervals'] != 'undefined') {
			intervalTextElm.innerHTML = SUGAR.language.languages.app_list_strings['repeat_intervals'][document.forms['CalendarRepeatForm'].repeat_type.value];

I have checked and re-checked all folder permissions and ownership.

This is set in my language file include/language/en_us.lang.php , which has permissions 775:

'repeat_intervals' => array(
        '' => '',
        'Daily' => 'day(s)',
        'Weekly' => 'week(s)',
        'Monthly' => 'month(s)',
        'Yearly' => 'year(s)',

Any thoughts?

I solved this problem after running all javascript repair tools. Re-running permissions chmod (for the umpteenth time).

Apparently I spoke too soon. Something is changing my permissions.

I run:

chmod -R 755 .
chmod -R 775 cache custom modules themes data upload config_override.php

and calendar displays just fine. Then, wait a while… and the error comes back. No calendar.

I Re-run the above permissions, and fixed (temporarily). I don’t see how something in the application could change the permissions, but am I missing something? What on the server might do this?

As always, help is much appreciated.

I have the same problem.

Any news about this?


You need to also set ownership when setting permissions and set the permissions in the config.php file.