Calendar stays in English

Hello everyone,

I have recently moved an installation to an Ubuntu 20.04 machine and updated to 7.11.19. Everything seems to work fine, however, the calendar doesn’t display weekdays and daytime in the selected Language.
I assume that fullcalendar defaults to “locale: en”.
It seems Cal.js sets locale as “locale: global_langPrefix”. Is global_langPrefix the language I selected while logging in or is there a setting I missed somewhere?
My users mostly want to use SuiteCRM in German.

Any help would be greatly appreciated

EDIT: I have also tried setting “locale: ‘de’” for testing in “jssource/src_files/modules/Calendar/Cal.js” and rebuilt JS. But that didn’t help either.

I made a PR months ago that changed some FullCalendar options.

I don’t quite remember what I did there, but I see I added the option in two places, not one. Maybe that can provide some clues for you…

Never mind the parts about adding the options to the UI, you probably don’t need any of those.

1 Like

Thank you for your response @pgr,

I have uncommented weekNumbers: true, as a test and it works.

I have also removed the ' ticks from locale: 'de', but the calendar wouldn’t load at all, so I assume that my syntax is correct?

But even setting it like this won’t work, is there any reason fullcalendar might not be able to load its translations?
Looking at the machine pre-update (7.11.18) I notice in the chrome “sources” tab that it loads lang-all.js from /modules/Calendar/fullcalendar/ but that’s missing in 7.11.19. Adding things manually doesn’t work unfortunately.


EDIT: found the following line is missing in 7.11.19 in “index.php?module=Calendar&action=index” not sure what file that is, found it looking through the chrome developer tools.

<script src='modules/Calendar/fullcalendar/lang-all.js?v=ByCDSUJzRtQZhWykrIljSA'></script>

That’s mysterious… probably related to this PR:

fullcalendar 3.10.2 from here still ships with lang-all.js and the lang folder but they have been renamed to locale-all.js and locale.

No idea if they’re unused as the commit says

I might have a window in the evening where I can try adding the deleted line back to modules/Calendar/tpls/main.tpl and see if it fixes things

1 Like

Putting back lang-all.js the lang folder and adding the line

<script src='modules/Calendar/fullcalendar/lang-all.js?v=ByCDSUJzRtQZhWykrIljSA'></script>

to modules/Calendar/tpls/main.tpl has indeed fixed things and the calendar now gets displayed in German.
I don’t really know my way around github very well. Anything I can help with to get this fixed in the sources?

Please post a comment on the Github PR linked above saying what your problem was, and how it is solved. Thanks!